Jackson Heart Study Protocol

Manual 11

Data Management System

Visit 1

Version 1.0

February 15, 2001

For Copies, Please Contact:

Jackson Heart Study Coordinating Center
Jackson Medical Mall
350 W. Woodrow Wilson Dr.
Jackson, MS  39213
FOREWORD

This manual is one of a series of protocols and manuals of operation for the Jackson Heart Study (JHS). The complexity of the JHS requires that a sizeable number of procedures be described, thus this rather extensive list of materials has been organized into the set of manuals listed below. Manual 1 provides the background, organization, and general objectives of the JHS Study. Manuals 2 and 10 describe the operation of the Cohort and Surveillance Components of the study. Detailed Manuals of Operation for specific procedures, including those of reading centers and central laboratories, make up Manuals 3 through 9 and 11.

JHS Study Protocols and Manuals of Operation

<table>
<thead>
<tr>
<th>MANUAL</th>
<th>TITLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>General Description and Study Management</td>
</tr>
<tr>
<td>2</td>
<td>Cohort Component Procedures</td>
</tr>
<tr>
<td>3</td>
<td>Family Study</td>
</tr>
<tr>
<td>4</td>
<td>Blood Pressure</td>
</tr>
<tr>
<td>5</td>
<td>Electrocardiography</td>
</tr>
<tr>
<td>6</td>
<td>Echocardiography</td>
</tr>
<tr>
<td>7</td>
<td>Ultrasound Assessment</td>
</tr>
<tr>
<td>8</td>
<td>Pulmonary Function Assessment</td>
</tr>
<tr>
<td>9</td>
<td>Specimen Collection and Processing</td>
</tr>
<tr>
<td>10</td>
<td>Cohort Surveillance</td>
</tr>
<tr>
<td>11</td>
<td>Data Management System</td>
</tr>
</tbody>
</table>
# MANUAL 11. Data Management System

## Table Of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>INTRODUCTION</td>
<td>1</td>
</tr>
<tr>
<td>1.1</td>
<td>Overview</td>
<td>1</td>
</tr>
<tr>
<td>1.2</td>
<td>Sample Data Management Workflow</td>
<td>1</td>
</tr>
<tr>
<td>1.3</td>
<td>Data Entry Help Menu and Glossary of Terms</td>
<td>3</td>
</tr>
<tr>
<td>1.4</td>
<td>References</td>
<td>3</td>
</tr>
<tr>
<td>2.0</td>
<td>DATA ENTRY GUIDE</td>
<td>5</td>
</tr>
<tr>
<td>2.1</td>
<td>Starting a Data Entry Session</td>
<td>5</td>
</tr>
<tr>
<td>2.2</td>
<td>Selecting the Protocol and Study Books</td>
<td>5</td>
</tr>
<tr>
<td>2.3</td>
<td>Accessing Forms Using the Clintrial Navigator</td>
<td>6</td>
</tr>
<tr>
<td>2.4</td>
<td>Enrolling Subjects</td>
<td>8</td>
</tr>
<tr>
<td>2.5</td>
<td>Entering Data</td>
<td>9</td>
</tr>
<tr>
<td>2.6</td>
<td>Clintrial-Supplied and Custom Reports</td>
<td>18</td>
</tr>
<tr>
<td>2.7</td>
<td>Closing Windows</td>
<td>19</td>
</tr>
<tr>
<td>2.8</td>
<td>Ending a Data Entry Session</td>
<td>19</td>
</tr>
<tr>
<td>3.0</td>
<td>PROGRAMMER GUIDE TO MANAGING DATA</td>
<td>21</td>
</tr>
<tr>
<td>3.1</td>
<td>Overview</td>
<td>21</td>
</tr>
<tr>
<td>3.2</td>
<td>Batch-Loading Data</td>
<td>21</td>
</tr>
<tr>
<td>3.3</td>
<td>Coding Data – not available at this time</td>
<td>24</td>
</tr>
<tr>
<td>3.4</td>
<td>Validating and Merging Data</td>
<td>24</td>
</tr>
<tr>
<td>3.5</td>
<td>Global Data Changes and Deletions</td>
<td>26</td>
</tr>
<tr>
<td>3.6</td>
<td>Logs and Reports</td>
<td>27</td>
</tr>
<tr>
<td>3.7</td>
<td>Closure Checks</td>
<td>29</td>
</tr>
<tr>
<td>4.0</td>
<td>PROGRAMMER GUIDE TO RETRIEVING DATA</td>
<td>31</td>
</tr>
<tr>
<td>4.1</td>
<td>Overview</td>
<td>31</td>
</tr>
<tr>
<td>4.2</td>
<td>SAS Retrieval for Custom Reports</td>
<td>31</td>
</tr>
<tr>
<td>4.3</td>
<td>SAS Retrieval for Data Analysis</td>
<td>31</td>
</tr>
<tr>
<td>4.4</td>
<td>Clintrial Retrieve Query By Form (QBF)</td>
<td>35</td>
</tr>
<tr>
<td>5.0</td>
<td>ADMINISTRATOR GUIDE</td>
<td>41</td>
</tr>
<tr>
<td>5.1</td>
<td>Data Entry Workstation Setup</td>
<td>41</td>
</tr>
<tr>
<td>5.2</td>
<td>System Parameters</td>
<td>44</td>
</tr>
</tbody>
</table>
5.3 Adding New User and Usergroup Accounts and Assigning Access Rights ......................... 47
5.4 Administering Clintrial and the Oracle Database.......................................................... 50
5.5 Blind Verification Procedure............................................................................................ 51
MANUAL 11. Data Management System

Tables and Figures

Figure 1  Data Entry Workflow ................................................................. 2
Figure 2  Data Management Workflow ........................................................ 2
Figure 3  The Navigator (Navigate by Page) ............................................... 7
Figure 4  Navigator Menu Commands ......................................................... 7
Figure 5  A study page ............................................................................. 10
This page is intentionally left blank.
1.0 INTRODUCTION

1.1 Overview

The Data Management System (DMS) is used to collect, process, and store information about participants in the Jackson Heart Study (JHS). This user guide describes the steps in the collection and management of data entered in the DMS during a center exam interview, from paper forms, or through batch-loading of an ASCII file.

The JHS DMS was developed using the Clintrial™ 4 (hereafter referred to as Clintrial) clinical research system software. Clintrial consists of a set of integrated core modules for data collection, management, and retrieval. This document specifically discusses the tasks using the Clintrial Enter module and Clintrial Manage module.

Clintrial Enter allows for data entry, editing, verification (double data entry), and storage of data in a JHS study database. Data checks are automatically performed during data entry by a check of a data value against predetermined edit specifications, and any value that fails a data check can be corrected immediately or flagged for future resolution. Built-in Clintrial reports and custom reports are available to check status of data entered and to look for any data inconsistencies.

Data are entered into update tables and are referred to as unmerged data in Clintrial while in the update tables. The data manager using the Clintrial Manage module moves data to the data tables. The update and data tables are in an Oracle database, and Clintrial handles the storage and use of these data tables in a way transparent to the user.

Using the Clintrial Manage module, a data manager can perform additional tasks in the management of the JHS data. The person in this role has extended access rights to the study data tables and familiarity with the Clintrial database structures. Tasks within the Manage module include batch-loading laboratory or ancillary data from an ASCII file, manual coding of medication data from industry-standard dictionaries, moving data from update tables to data tables, making global changes or deletions across multiple records, and reviewing processing logs and error or change reports.

1.2 Sample Data Management Workflow

Section 2 of this document provides the step-by-step instructions on each task for data entry. Figure 1 gives a visual representation of the data entry workflow.

Section 3 of this document describes other tasks that are performed in the management of the JHS data. Figure 2 shows a data management workflow of the data entry and management tasks for the DMS.
Figure 1  Data Entry Workflow

- Login to Clintrial and Start Data Entry Session
- Set the Protocol
- Set the Study Book
- Enroll Subjects
- Enter Data, Add Flags and Notes
- Verify (Re-enter) Data
- Edit Data
- View Reports
- End Data Entry Session and Logout of Clintrial

Figure 2  Data Management Workflow

- Enter Data (see Figure 1)
- Batch Load and Screen Laboratory and Ancillary Data
- Code Data from Dictionaries
- Validate Data
- Make Global Changes and Deletions in Update Table
- Merge Data from Update to Data Tables
- Make Global Changes and Deletions in Data Table
- View Logs and Reports
- Retrieve to Analysis Files

Automatic Data Checking, Automatic Flags
View Error Log
1.3 Data Entry Help Menu and Glossary of Terms

The Help menu includes step-by-step instructions to perform tasks in Clintrial along with overviews of concepts and descriptions of the menus and options. A glossary provides an extensive dictionary of special Clintrial terms.

To search for information in Help:

1. Select Help > Help Topics.
2. To find a topic in the Help Topics dialog box:
   a) Click on the Contents tab for topics by category.
   b) Click on the Index tab for index entries.
   c) Click on the Find tab for a search on specific words.
3. For the glossary of terms, click on the Contents tab and then double-click on Glossary at the top of the list.

Additionally for help on an open window or dialog box, press F1.

Some of the Clintrial terms and their descriptions that are found in this document are as follows:

Protocol – a Clintrial account that consists of the data and other components used by the DMS for a research study.

Study Book – an online representation of a list of the data collection forms. Each study book contains an ordered list of study pages grouped into blocks.

Block – a group of related study pages in a study book, usually representing a visit or contact occasion.

Study Page – a data entry window that usually corresponds to a single data collection form, however some forms have multiple study pages because of a length limitation of the data entry window template.

Study Page Number – a sequential number assigned to the study pages in their alphabetical order (usually) by form-version.

Repeating Page – a single block of study pages that can be repeated multiple times for repeated visits (only twice in the JHS DMS). A repeat visit is optional and rare for the baseline visit. A block repeat key value uniquely identifies a repeat of a block and is stored in the block repeat key item that is a visit-related context (key field) item. The block repeat key value is entered during data entry for a repeated visit from a drop-down list of values.

Subject – a participant in a research study for whom data are entered in the DMS.

1.4 References

Information for this instruction manual for JHS comes from the Clintrial® 4 Release 4.2 software manuals and from the Clintrial 4.2 Design Training Guide published by Domain Pharma Corporation. Clintrial is a trademark of Domain Pharma Corporation.

The current release of Clintrial 4.2 stores data in an Oracle8 database. Oracle is a registered trademark of Oracle Corporation.

The SAS® System Version 8 from SAS Institute Inc. is used in writing the custom reports and for the data retrieval process in the JHS DMS.
This page is intentionally left blank.
2.0 DATA ENTRY GUIDE

2.1 Starting a Data Entry Session

2.1.1 Logging In

You must login to a Clintrial session to access the JHS DMS for data entry. The steps to login and start a data entry session is as follows:

1. From the Windows Desktop, double-click on the JHS Data Entry icon. As an alternative, select Start > Programs > Clintrial 4.2 > Clintrial Enter.
2. The Database Connection dialog box is displayed. Login to Clintrial, as follows, with the information that was set up for your user account:
   a) Enter your Clintrial User Name.
   b) Enter your Password.
   c) Enter the character string @ORC0 for Database.
3. Click OK to leave the dialog box.

The first time you start a Clintrial session, the fields in the Database Connection dialog box are empty. The next time you start a session, the user name and database that you last used to start Clintrial are displayed as defaults in the dialog box.

On a successful login, you are in the Clintrial Enter window.

2.1.2 Changing a Password

If you want to change your Clintrial password for any reason, do the following:

1. From the Clintrial Enter window, select File > Password.
2. In the Password dialog box, follow the instructions to set up a new password. Click on OK to finish.

A password must conform to the Clintrial password minimum length currently set at 6, must consist of alpha and/or numeric characters (other symbols and spaces not allowed), and cannot begin with a number. A password is not case sensitive.

If you have any difficulty getting started in Clintrial or forget your current user name and/or password, see your Database Administrator (DBA).

2.2 Selecting the Protocol and Study Books

2.2.1 Overview

This DMS organizes data for the different components of this study into protocols. One protocol named JHS_COHORT comprises the data from the Baseline Visit (enumeration, home induction interview, center exam, and 24-hour exam) and the annual contacts (annual contact details are not yet available). The Surveillance and Family Study components of this study will be organized into two additional protocols (details are not yet available).

The data in JHS_COHORT are organized into study books. A study book represents the collection of data collection forms called study pages grouped into visits called blocks. The study books in JHS_COHORT are as follows:

- INTERVIEW (enumeration and home induction interview data)
- EXAM (center exam and 24-hour exam data)
• **ANNUAL** (annual follow-up data, not yet available)

An enrollment study book named **ENROLL** is available exclusively to enroll new study participants. A participant must be enrolled before any data can be entered for that participant.

### 2.2.2 Setting the Protocol and Study Book

The first time you start the JHS DMS for data entry, you must set the protocol and study book.

To set the protocol, do as follows:

1. In the **Set Protocol** dialog box, click to highlight the protocol in which you want to work, for example, **JHS_COHORT**.
2. Click on **OK** to continue.

The next time you start the DMS, Clintrial automatically selects the protocol that you last used and asks if you want to use the protocol selected. Click on **Yes** to select the protocol; click on **No** to enter the **Set Protocol** dialog box to select another protocol.

After setting the protocol, set the study book as follows:

1. The **Set Study Book** dialog box opens automatically after you set the protocol. Click to highlight the study book in which you want to work, for example, **INTERVIEW**.
2. Click on **OK** to continue.

Clintrial automatically chooses the study book that you used during your last session on subsequent logins to the DMS. A message is displayed asking you to confirm that this is the study book you want to use. Click **Yes** to select the study book; click **No** to enter the **Set Study Book** dialog box.

### 2.3 Accessing Forms Using the Clintrial Navigator

#### 2.3.1 Overview

The best method to access forms within each study book is by using the Clintrial **Navigator**. The Navigator is a browser that graphically displays the **blocks**, **study pages**, and **subjects** in a **study book**. The Navigator uses **icons** to uniquely identify these objects, and a double-click on an icon opens that object in the Navigator. **Figure 3** shows the Navigator in the navigation order of **Navigate by Page**.

In the Navigator for the JHS DMS, the study pages are listed in ascending order of their study page number. Note that some forms have multiple study pages (indicated as Part 1, Part 2, etc.) due to a length limitation in the design of the data entry window templates.

The Navigator menu commands offer another method to navigate through the sequence of forms and subjects in a study book. A description of the menu commands is in **Figure 4**.

The Help menu provides more detailed instruction in the use of the Clintrial Navigator.
Figure 3  The Navigator (Navigate by Page)

![Navigator Window]

Figure 4  Navigator Menu Commands

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go To</td>
<td>Open a form by using the Go To dialog box. Enter ID NUMBER, CONTACT YEAR, and PAGE number.</td>
</tr>
<tr>
<td>Go To Selected</td>
<td>Go to the study page highlighted in the Navigator.</td>
</tr>
<tr>
<td>Next*</td>
<td>Go to the next study page in the navigation order.</td>
</tr>
<tr>
<td>Previous*</td>
<td>Go to the previous study page in the navigation order.</td>
</tr>
<tr>
<td>Next Subject</td>
<td>Go to the current study page for the next subject.</td>
</tr>
<tr>
<td>Next Page</td>
<td>Go to the next study page for the current subject.</td>
</tr>
<tr>
<td>Previous Subject</td>
<td>Go to the current study page for the previous subject.</td>
</tr>
<tr>
<td>Previous Page</td>
<td>Go to the previous study page for the current subject.</td>
</tr>
<tr>
<td>Navigate by Subject</td>
<td>Set the navigation order to By Subject (list of subjects under each study page).</td>
</tr>
<tr>
<td>Navigate by Page</td>
<td>Set the navigation order By Page (list of study pages under each subject).</td>
</tr>
<tr>
<td>Expand</td>
<td>Expand the selected Navigator order.</td>
</tr>
<tr>
<td>Collapse</td>
<td>Collapse the selected Navigator order.</td>
</tr>
<tr>
<td>Sort Subjects</td>
<td>Set the sort order for subjects in Navigator as ascending or descending.</td>
</tr>
<tr>
<td>Navigator</td>
<td>Open the Navigator.</td>
</tr>
</tbody>
</table>

*Depending on the Navigation order selected, **Next** or **Previous** opens either the next or previous page for the current subject (**Navigate by Page**), or opens the current page for the next subject (**Navigate by Subject**).
2.3.2 Using the Navigator

For the JHS DMS, the Navigator is set to open automatically whenever you open a study book. If Navigator does not open automatically, select the **Navigate > Navigator** menu commands.

This section describes the Navigator in navigation order **Navigate by Page** that is the recommended navigation setting for the JHS DMS. For Navigate by Page, the Navigator **icons** as shown in **Figure 3** are as follows:

- **Subject** – a **book** (closed if collapsed, open if expanded)
- **Block** – a **boxed arrow** (right arrow if collapsed, down arrow if expanded)
- **Study page** – a **page**
- **Repeating page** – **overlapping pages**

An icon is shaded if any data are present.

As displayed in **Figure 3**, the study book **EXAM** is open and contains one block called **CENTER EXAM** with the study pages grouped under each subject. For JHS, the study pages are listed in alphabetic order by form code. To expand or collapse a subject, block, or study page, double-click on its icon.

The Contact Information form in the INTERVIEW study book is designed as a **repeating page** to allow for the possibility of additional data from a repeat contact with a subject. For the first Contact Information form, enter the repeating page number as 0 (zero) when prompted. Enter repeating pages as consecutive numbers 1, 2, etc.

### 2.4 Enrolling Subjects

#### 2.4.1 Overview

A new subject must be enrolled in a protocol before any data can be entered for that subject. The DMS allows for enrollment of new subjects either in the ENROLL study book or within a study book prior to entry of any data. **It is recommended to enter a new subject within a study book from the File menu due to current Clintrial limitations that may cause loss of data using the ENROLL study book.**

Enrollment data are the subject-related items ID NUMBER, LAST NAME and INITIALS appearing at the top of the first page of each form. These are required fields in the DMS, and the fields must contain data to continue data entry.

#### 2.4.2 Adding New Subjects

**Enrolling subjects in a data study book (recommended)**

If you are only adding a few subjects at a time along with their data, you can enroll the new subjects from within a data study books.

To enroll a new subject, do as follows:

1. Select the **File > New Subject** menu commands to open the **New Subject** dialog box.
2. Enter **ID NUMBER**, **LAST NAME** and **INITIALS** in the Enrollment Information section.
   a) ID NUMBER is a unique subject identifier. If you enter a non-unique subject identifier into the DMS, Clintrial displays a message that you cannot enroll the subject since the subject has already been enrolled.
   b) Since these are required fields, if INITIALS or LAST NAME is not available then enter X's in the field. For example, enter the household last name for LAST NAME and X's for INITIALS for enrollment of a Household ID.
c) Use the Tab key to move from one field to another. If you use the Enter key, Clintrial attempts to leave the New Subject dialog box, and if any fields are blank, it displays a message to enter data in the highlighted fields which you must do before you can leave this dialog box.

3. After completing the subject enrollment information, click one of the following:
   a) Go To Page to save the subject information and to go to the subject’s first study page.
   b) Add Next to save the subject information and add another new subject (repeat items 2 and 3).
   c) OK to save the subject and to close the New Subject dialog box.

To modify or delete any subject information in the New Subject dialog box that have not yet been saved, do one of the following:

1. To modify the subject information, place the cursor in the field you want to modify, delete the old information and enter the new information.
2. To delete the subject information, click on Cancel to delete the information and exit from the New Subject dialog box.

Enrolling subjects in the enrollment study book (not recommended)

The enrollment study book contains only one study page that opens automatically when you open the ENROLL study book. Using the enrollment study book is most effective when you are enrolling a group of subjects prior to entry of any data, or when you want to view or print a list of enrolled subjects.

To enroll a subject in the enrollment study book, do as follows:

1. Select the File > Set Study Book menu commands. Highlight ENROLL and click OK to continue.
2. The SQL Restriction Clause Builder window automatically opens. Click Cancel or OK to continue. SQL restrictions are not being used at this time.
3. The cursor is on the first field to enter a new subject. Enter ID NUMBER, LAST NAME and INITIALS. Use either the Tab or Enter key to move to the next field.
4. To enter additional new subjects, press Ctrl-A or select the Edit > Add Subject menu commands. Enter each new subject as in step 3. Repeat these steps until you enter the last subject.
5. Close the enrollment study page by clicking on the (X) windows button for the page or select the File > Close menu commands.

To modify or delete any subject information in the enrollment study book that have not yet been saved, do one of the following:

1. To modify the subject information, place the cursor in a field belonging to the subject you want to modify, delete the old information and enter the new information.
2. To delete the subject information, place the cursor in a field belonging to the subject you want to delete and select Edit > Delete Subject from the menu commands.

Modifying and deleting subject information after data have been saved

Once a subject’s enrollment data have been saved by either enrollment method, you cannot modify the enrollment data in the Clintrial Enter module. Modification to saved enrollment data must be done in the Manage module by the Data Manager.

2.5 Entering Data

2.5.1 Overview

Data are entered in a study page that is a representation of the data collection forms. Some forms have multiple study pages due to form length limitations in the design of the data entry screen templates. Flags and notes are information about data that can be attached to fields or a study page during data entry.
**Figure 5** shows an example a study page open for data entry.

**Figure 5  **Study page

![Image of study page]

### 2.5.2 Adding New Data

#### 2.5.2.1 Characteristics of Form Fields

**Field Types**

Several types of fields appear in a study page:

- **Enterable fields** are fields in which you can enter data. These fields have a white background and can accept the cursor.
- **Non-enterable fields** are fields in which you cannot enter data. These fields have a colored background (usually gray) and will not accept the cursor. Examples are computed fields and skipped fields that follow a skip trigger field.

**Data Types**

Each field has been assigned a **data type** attribute. The following data types are used in the JHS DMS:

<table>
<thead>
<tr>
<th>Field Type</th>
<th>Data Type</th>
<th>Description and Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric</td>
<td>FIXED</td>
<td>An integer that cannot include a decimal point. The integer can be prefaced with a plus or minus sign. Example: 100.</td>
</tr>
<tr>
<td>Data Type</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Numeric</td>
<td>A number that can include a decimal point. The number can be prefaced with a plus or minus sign. Example: 25.6</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>A date in the format mm/dd/yyyy (month/day/year). Leading zeroes are accepted but not required for month and day. Missing date parts must be estimated, e.g., 01 for missing month or day. Enter a slash or hyphen as the delimiter separating date parts. Example: 06/20/2000</td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td>A character string that can include letters, numbers, punctuation marks, spaces, and special characters. Enter character strings in upper case. Partial dates (mm/yyyy) and times (hh:mm) are entered as character strings since Clintrial does not have a comparable data type. Examples: J123456, ASPIRIN, 09/2001, 04:45</td>
<td></td>
</tr>
</tbody>
</table>

Note the following for date field types:
- From the Clintrial Help menu, “Years can be entered as two digits or four. When a two-digit year is entered, Clintrial stores numbers 00 to 49 as 21st century (2049) and numbers 50 to 99 as 20th century (1950).” It is important to enter year as a 4-digit number to ensure the correct century.
- Although the Clintrial date uses the DATE data type, a date is stored with the DATETIME data type in the Oracle database. In rare cases during data entry, you may see a date field type displayed in DATETIME format.

**Value Ranges**

Most numeric and date fields have lower and upper bounds. You must enter a value within the specified limits. However, if the correct value is outside these bounds, the JHS DMS has been designed to allow you to enter a value that overrides these bounds.

If you enter a value outside the bounds, Clintrial issues a message that the item value is outside the range and asks if you want to override and accept this value. You can accept or not accept the value, with the following actions:

- **If you do accept this value,** Clintrial will attach a flag to the field and a red flag icon will appear to the right of the field (see Using Flags for more information). The cursor will move to the next field.
- **If you do not accept this value,** the value of the field will return to its previous state (either blank or a previously entered value), and the cursor will move to the next field (unfortunately a Clintrial feature with the autoskip functionality). You must return to the previous field that invoked the message by pressing Ctrl-Tab or clicking on the field to enter the correct value.

**Drop-Down Boxes**

Drop-down boxes are used for fields that have a list of acceptable values, such as a list containing Yes, No and Don't Know. You can only select the values that appear in the list for the field. You can enter a value in the field in one of the following ways:

- **Enter the code associated with the value in the list,** such as Y for Yes. The value appears in the field.
- **Click on the down arrow button to display the list.** To select a value, press the keyboard key that corresponds to the value’s first letter or click on the value. The value appears in the field. Long lists will have a scroll bar to move down the list of values.

You may encounter a value in a drop-down list that cannot be selected if that value has become obsolete. The value will be displayed as red text.
Missing Data

There are no special character or numeric entries for missing data in the JHS DMS. Simply leave the value blank. For the JHS DMS, it is recommended to add a flag called PERMANENTLY_MISSING to the field (see Using flags). Add a comment in the Item Flag dialog box to indicate the reason for permanently missing.

To change a field with data to missing, delete the value in the highlighted field by pressing the keyboard Backspace key or selecting the Edit > Clear menu commands. To change data to missing for a field with a drop-down list, select (None) from the drop-down list.

Using Item Help

You can view the attributes of any enterable field on a study page in the Help menu. Item Help displays the attributes of a field defined during the development of the DMS. To open Item Help, do the following:

1. Highlight the field whose attributes you want to view.
2. Select Help > On Current Item from the menu commands, or press Shift-F1.
3. Close the Item Help window by clicking on the (X) windows button.

2.5.2.2 Navigating in a Form

Navigating between fields

The following keyboard commands allow you to navigate between fields on a study page:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab or Enter</td>
<td>Next field.</td>
</tr>
<tr>
<td>Shift-Tab or Shift-Enter</td>
<td>Previous field.</td>
</tr>
<tr>
<td>Ctrl-Home</td>
<td>First field in page section (a partition of the study page).</td>
</tr>
<tr>
<td>Ctrl-End</td>
<td>Last field in page section (a partition of the study page).</td>
</tr>
</tbody>
</table>

Navigating within a single field

The following keyboard commands allow reposition of the cursor and selection of text within a field:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Moves cursor to the beginning of the field.</td>
</tr>
<tr>
<td>End</td>
<td>Moves cursor to the end of the field.</td>
</tr>
<tr>
<td>Ctrl-Right Arrow</td>
<td>Moves cursor one word to the right.</td>
</tr>
<tr>
<td>Ctrl-Left Arrow</td>
<td>Moves cursor one word to the left.</td>
</tr>
<tr>
<td>Escape</td>
<td>Restores a non-coded field to its original value.</td>
</tr>
<tr>
<td>Shift-Home</td>
<td>Selects text from cursor position to the beginning of the field.</td>
</tr>
<tr>
<td>Shift-End</td>
<td>Selects text from cursor position to the end of the field.</td>
</tr>
<tr>
<td>Shift-Right Arrow</td>
<td>Selects one character to the right.</td>
</tr>
<tr>
<td>Shift-Left Arrow</td>
<td>Selects one character to the left.</td>
</tr>
<tr>
<td>Ctrl-Shift-Right Arrow</td>
<td>Selects one word to the right.</td>
</tr>
<tr>
<td>Ctrl-Shift-Left Arrow</td>
<td>Selects one word to the left.</td>
</tr>
</tbody>
</table>

Autoskip (currently disabled in the JHS DMS)

The JHS DMS uses the Clintrial automatic skipping feature that automatically advances the cursor to the next enterable fields. This feature is not available from fields with drop-down boxes. Autoskip will only advance if the maximum number of characters have been entered in the current field, so if the entry is
less than the maximum length, you will need to advance to the next field using the Tab or Enter key or clicking on the field.

**Go To skips**

A field in a form may display an instruction that entry of a particular value for that field causes a skip of one or more fields to a latter field. The field that causes a skip is called a trigger field, and the field to skip to is the target field. For a trigger field, the paper copy of the form displays a ‘Go to’ statement beside the trigger value for that field, and the data entry window displays an asterisk (*) beside the trigger value for that field.

If you enter a trigger value in a trigger field in the DMS, then the cursor goes to the target field and marks the skipped fields as non-enterable fields. If the value of a trigger field is changed, the skipped fields become enterable.

A few exceptions for skips in the JHS DMS are as follows:

- The target field may be too far from the trigger field for a skip in Clintrial. Therefore, a message is displayed to skip to the target field, and then the skip will go to the farthest field it can reach. Use the Tab or Enter keys to go the remaining distance to the target field.
- The skipped fields may not be marked as non-enterable due to Clintrial limitations in certain locations in a page design.

**Scrolling in a study page**

As you perform data entry in a study page, the Tab or Enter key move the cursor to the next enterable field on the study page, automatically scrolling down the page and displaying the fields in the data entry window. You can manually scroll down a page by using the vertical scroll bar on the right side of the window.

Some study pages are designed from forms with a landscape layout and require scrolling left to right. The Tab or Enter key moves the cursor to the next enterable field, automatically scrolling to the right on a page and displaying the fields in the data entry window. For these wide pages, a horizontal scroll bar is available at the bottom of the data entry window that you can use to scroll manually from left to right.

**Search field**

At the bottom of the Navigator window is a Search field in which you can enter text (case sensitive) to search for a particular study page. The search begins at the currently selected icon and proceeds within the hierarchy until the first match is found. You can only search expanded icons.

For example, to find the next occurrence of the SBPE Sitting Blood Pressure study page in the CENTER EXAM block for subject J000000, expand the subject and CENTER EXAM icons and then enter “S” in the Search field. The search begins as soon as you enter any text. Continue to enter additional characters in the text until the search takes you to the SBPE study page.

**Last field action**

When the cursor is on the last field of the study page, pressing the Tab or Enter key will move the cursor to the first field of the study page. You do not exit from the study page.

**Printing study pages**

You can print study pages from the Navigator without having to open them. Only study pages that contain data can be printed, and only study pages and subjects included in the current subject list and page list can be selected for printing.
The Navigator provides several options to print for selecting one or more individual study pages or subjects or selecting a selected group of study pages or subjects. These options differ depending on the current navigation order setting.

From the Navigator window in the navigation order Navigate By Page, you can select for printing as follows:

1. Select subject(s) or study page(s) to print.
   a. Selecting an individual subject prints all study pages for the subject
   b. Selecting one or more individual study pages for a subject prints the individual study page(s) for the subject.
   c. Selecting the Edit > Select All menu command prints all the study pages in the study book.
2. Select File > Print from the menu commands. In the Print Options dialog box, you can make further selections on study pages to print, if desired.
3. Click on OK to print and to close this dialog box.

2.5.2.3 Using flags

Flags can be attached to an individual field as an Item Flag or to a form by way of a Record Flag. Flags are typically used to:

- Label and monitor data quality problems.
- Capture information that cannot be entered in the fields on a screen.

For example, a flag might be added to a field where the data are missing or where the data are outside a specified range of values.

Flags have two parts:

- A flag category is used to indicate the type of problem or assertion found with the data, such as ILLEGIBLE or MISSING.
- A flag name is associated with a single flag category.

In the JHS DMS, there are four categories of flags with each category associated with a single name (the same value as the category). The categories (and names) and their description are as follows:

<table>
<thead>
<tr>
<th>FLAG CATEGORY (AND FLAG NAME)</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>OVERRIDE</td>
<td>Use when overriding an edit range.</td>
</tr>
<tr>
<td>PERMANENTLY_MISSING</td>
<td>Use when a field value or form is permanently missing.</td>
</tr>
<tr>
<td>CANT_ENTER</td>
<td>Use to indicate when a value cannot be entered into the field (e.g., if a field is too short or if a value is different from the field type).</td>
</tr>
<tr>
<td>QUERY</td>
<td>Use only when entering data from paper forms to indicate that a field should be queried.</td>
</tr>
</tbody>
</table>

There are other flag categories supplied by Clintrial that cannot be removed but are not used for JHS. The flag categories to ignore for JHS are CDR, GENERAL, CLASSIFY, and LABLOADER.

To attach a flag to a field, do the following:

1. With the cursor in the field, select Flags > Item Flag menu commands.
2. In the Item Flag dialog box, select a **Category** from the list. Select a **Name** from the list (same as **Category**). Enter text in the **Comment** field to provide a reason for the flag.
3. Click **OK** to continue. The dialog box closes, and a red flag icon appears next to the field.

You attach a flag to a record for a form-level flag, for example, if the entire form is permanently missing. A single form is usually comprised of multiple records appended together, with each record containing a subset of the form fields. Only attach a flag to the first record for a form-level flag. To attach a flag to the first record, do the following:

1. With the cursor in the first field on a study page, select **Flags > Record Flag**. Note that the cursor is automatically positioned in the first field of the study page when the study page is opened.
2. In the Record Flag dialog box, select a **Category** from the list. Select a **Name** from the list (same as **Category**). Enter text in the **Comment** field to provide a reason for the flag.
3. Click **OK**. The dialog box closes, and a red flag icon appears next to the record (top right of form).

Multiple flags can be attached to an item or a record, but only one red flag icon will appear.

### 2.5.2.4 Using notes

Notes are used to enter comment fields and ‘Other’ responses or to make notes about an individual field in a study page or about an entire study page. A note for a field is attached as an Item Note. An example: a note for the reason text to the field ‘Other Reason’. A note for a form is added as a Record Note. An example: if a study page cannot be completed, then a record note can indicate why the data are unattainable.

Notes have two parts:

- **Note category** defines the source of the note.
- **Note name** defines a subcategory for the source of the note.

Clintrial supplies two note categories of **SPONSOR** and **INVESTIGATOR**, and in **INVESTIGATOR**, there is one note name. **For JHS, all notes will be note category INVESTIGATOR with note name UNSPECIFIED**. The other note categories are not meaningful in JHS, but cannot be removed in Clintrial.

To attach a note to a field, do the following:

1. With the cursor in the field, select **Notes > Item Note** menu commands
2. In the Item Note dialog box, select **INVESTIGATOR** from the **Category** list. Select **UNSPECIFIED** from the **Name** list. Enter the text in the **Note Text** field to provide a comment or ‘Other’ reason.
3. Click **OK** to continue. The dialog box closes, and a yellow note icon appears next to the field.

You attach a note to a record for a form-level note. A single form is usually comprised of multiple records appended together, with each record containing a subset of the form fields. Only attach a note to the first record for a form-level note. To attach a note to the first record, do the following:

1. With the cursor in a field belonging to the record, select **Notes > Record Note**. Note that the cursor is automatically positioned in the first field of the study page when the study page is opened.
2. Select a **Category** from the list. Select a **Name** from the list. Enter text in the **Note Text** field to provide a reason for the note.
3. Click **OK**. The dialog box closes, and a yellow note icon appears next to the record (top right of form).

Multiple notes can be attached to an item or a record, but only one yellow note icon will appear.

### 2.5.2.5 Saving data and exiting a study page
Data entered in a study page are not permanent until the study page is saved. You can save at any time during data entry in a study page or when you exit from a study page.

The following options are available to save data and/or to exit from a study page:

- Select **File > Save** menu commands to save data without exiting from the study page.
- Select **File > Close** menu commands or click the study page (X) windows button to save data and exit from the study page.
- Select **File > Close Without Saving** to exit the study page without saving data.

### 2.5.3 Creating and Selecting Subject Lists

Long lists of subjects in the Navigator can make data entry cumbersome. To limit the number of subjects displayed in the navigation window, such as to those attending the center that day or to those who are in the stack of forms for data entry, you can specify a subset of subjects by using **subject lists**. You can create as many subject lists as needed and save these lists indefinitely.

Every Clintrial protocol has a default subject list called **All** that includes all subjects enrolled in the study. This list cannot be deleted or modified.

You create and modify subject lists using the **List Wizard**. The Wizard is a series of dialog boxes to guide you through the steps of entering or modifying list criteria. To create a list in the Wizard, select specific subjects to include. You can optionally include or exclude subjects based on a SQL restriction. You can also create a list that includes or excludes subjects based upon the presence or absence of flags or notes. Once created, a list can be modified as needed.

To open the List Wizard, select one of the following menu commands appropriate to what you want to do:

- **List > Create List**
- **List > Edit Subject List**

You can select a particular subject list for the Navigator to display, and only those subjects belonging to the list will be displayed. To select a subject list, do one of the following:

- From the **Subject List** drop-down box at the top left of the Navigator window, select the list you want.
- Select **List > Select Lists** from the menu commands. In the Select Lists dialog box, select the subject list you want and click **OK** to continue.

### 2.5.4 Browsing, Changing, Deleting, or Printing Data in the Enter Module

**Browsing Data**

To browse data in a saved study page in the update table, double-click on the study page icon to re-open the study page in the Navigator. Use the scroll bar or the Tab or Enter key to browse through the data, being careful not to change inadvertently any data. Select **File > Close Without Saving** to exit from the study page.

**Changing Data**

There are three edit modes available in an Enter session to change data:

- **Edit Update Data** (default) - enter new data or edit unmerged data.
- **Verify** - perform verification of previously entered data.
- **Edit Merged Data** - edit data that have been validated and merged (moved) to the data table (merging data is described later in Managing Data).
By default, when you start Enter, the edit mode is set to Edit Update Data. If you want to perform verification or edit merged data, you must set the edit mode to one of these other options. All study pages must be closed before you set the edit mode. The name of the current edit mode is displayed in the title bar of the study page. To change the edit mode, select **File > Edit Mode**. Select an edit mode, then click **OK** to continue.

To change data in a saved study page, double-click on a study page icon to re-open the study page in the Navigator. Use the scroll bar or the Tab or Enter key to move through the study page. Select a field to change, then enter the data. Select **File > Save** to save the changed data without exiting or **File > Close** to save and exit from the study page.

**Deleting Data**

Depending on the situation, you can delete data in an open study page in following ways:

- Close a study page without saving new or updated data
- Undo data entered since the last save
- Delete data from a field
- Delete all data for a study page

To close an open study page and not save data, select **File > Close Without Saving**. For example, if you inadvertently open the wrong study page from the Navigator, close the study page without saving to avoid creation of any blank records in an update table and to not shade the study page icon.

If you want to undo data entered since last save in an open study page, select **Edit > Undo Page Edits**.

If you want to delete data from a field in an open study page, highlight the field and select **Edit > Clear** or use the **Delete** key. To delete or clear a value from a codelist field, highlight the field and select (None) from the drop-down list. Select **File > Save** to save data deletions without exiting or **File > Close** to save and exit from the study page.

If you want to delete all data in a previously saved study page, select **Edit > Delete Page Data** in the open study page and click on **Yes** to confirm the deletion. The study page will automatically close, and the study page icon will not be shaded.

**Printing Data**

You can print Clintrial reports, most non-report windows, and study pages. You can open a study page for printing or print from the Navigator window. If the Print or Print Preview command is not available for a displayed window, then that window does not have the print or preview capability.

Select **File > Printer Setup** to specify which local or network printer to use. Depending on your printer, you can also adjust certain printer defaults like page orientation, paper size, and print resolution. Consult your printer's documentation or your Clintrial Data Manager for more information.

To print from within a report, window, or open study page, do as follows:

1. Select **File > Print**.
2. The Print Options dialog box opens. Accept default settings or modify any of these values as needed.
3. Click **OK** to print.

To preview a document, select **File > Print Preview**. Previewing a document before printing lets you see how the text will look when printed, shows certain report features that do not normally display on the screen (e.g., headers and page numbers), and allows an opportunity for an adjustment to page orientation for best printing results.
You can print study pages from the Navigator without having to open them. Only study pages that contain data are printed. Only study pages and subjects included in the current page list and subject list can be selected for printing. However, use this print capability with caution. To print multiple study pages at a time is dependent on the number of allowable open study pages set for system parameter ENT_OPEN_PAGES (default is 1). Set ENT_OPEN_PAGES temporarily to the maximum of 10 to print study pages from the Navigator. Otherwise, you will get a Clintrial error that terminates Enter if the number of study pages to print exceeds the number specified by this parameter except if set to 10.

To print study pages from the Navigator, do as follows (assumes Navigate By Page navigation order):

1. Select the page(s) that you want to print in one of following ways:
   a. Click on one or more individual study pages within a subject (Shift-click for more than one)
   b. Click on a block (i.e., CLINIC EXAM) to print all study pages in the block for that subject
   c. Select Edit > Select All to print all the study pages for all subjects in the study book
2. Select File > Print.
3. The Print Options dialog box opens. Accept default settings or modify any of these values as needed.
4. Click OK to print.

2.6 Clintrial-Supplied and Custom Reports

Clintrial-Supplied Reports

Clintrial provides Enter reports that you create through the use of a Report Wizard. Within the Wizard, you enter criteria that determine the report's format and content in a series of dialog boxes.

You can create one of the following reports:

- A Flag Report, which displays information about flags that have been attached to data in the current study book.
- A Note Report, which displays information about notes that have been attached to data in the current study book.
- A Subject Report, which displays information about the status of data entered for study subjects.
- A Verification Report, which displays information about records that have failed to pass blind verification.

The Flags, Notes, and Subject reports are available in two basic formats: detailed and summary. The detailed format provides in-depth information on each record matching the selection criteria. The summary format gives a count and categorical breakdown of records matching the selection criteria.

To create a Clintrial-supplied report, do as follows:

1. To open the Report Wizard, select Reports from the Enter menu and then select the type of report: Subject, Flag, or Note.
2. Select the criteria for the report. Click Next to move to the next dialog box. Click Back to return to a previous dialog box to change an earlier entry.
3. Select Finish to end your selection and view the report. As soon as the Finish button is available, it indicates that the minimum amount of necessary information has been entered.
4. The report appears on the screen. You can also print the report (File > Print) or save the report to a file in a directory of your choice (File > Save As).

Custom Reports

Custom reports developed for JHS such as recruitment status, participant profiles, and lab results can be run from the Custom menu in Enter. The Custom menu is a user-modifiable menu in which you can set up shortcuts to Windows applications (e.g., Notepad, Excel), to specific document files (e.g., text files,
spreadsheets), and to the SAS System to run JHS data reports. These applications and documents can be directly opened from Clintrial in the Custom menu.

When creating a shortcut, you can specify whether the shortcut appears in every Clintrial module you use (create in **Common Menu Items**) or in only the module from which it was created (create in **Module Specific Menu Items**). You can create up to eight shortcuts of each type.

*Custom menu items will appear only on the workstation on which they were created since they are stored in the Windows Registry. For computers running under Windows NT, Custom menu settings are also particular to the user who created them.*

### 2.7 Closing Windows

When you have completed data entry using the Navigator or completed other tasks in a DMS window, you need to close the active task window.

To close a window, you can use one of several options:

- Click on the rightmost (X) windows button at the far top right of a window.
- Select the **File > Close** menu commands.
- Click on the **OK** button, if provided (in dialog boxes).
- Click on the **Finish** button, if provided (in List or Report Wizard).

### 2.8 Ending a Data Entry Session

To close the Clintrial Enter window and end your DMS session, click on the rightmost (X) windows button or select the **File > Exit** menu commands.
3.0 PROGRAMMER GUIDE TO MANAGING DATA

3.1 Overview

In the Clintrial Manage module, a Clintrial Data Manager can perform data management tasks such as the following:

- batch-load data
- assign codes based on field values from industry-standard dictionaries
- validate data, that is, calculate derived fields and run consistency checks
- merge or move data that have passed validation from update to data tables
- globally change or delete records
- view processing logs and reports
- view error reports and make corrections
- view audit trail reports

A typical data management workflow in the Manage module is displayed in the introduction of this manual.

A person using the Manage module has privileged access rights to the study data tables and has familiarity with the Clintrial database structures.

3.2 Batch-Loading Data

3.2.1 Overview

Batch-loading is the process of loading data from ASCII files directly into update tables in the Clintrial database. You can batch-load study data, enrollment data, and thesaurus (dictionary) data.

Enrollment data must be previously entered for a subject whose data are batch-loaded. Either the subject is enrolled in the Enter module, or the enrollment data are batch-loaded, screened, validated, and merged before study data can be entered for the subject.

The input ASCII file contains records composed of data fields. The data fields on a record correspond to items in a pre-defined panel into which the data are batch-loaded. You can only batch-load into one panel at a time. To load data from one input ASCII file into more than one panel is a complicated, multiple control files, multiple runs process not discussed in this manual.

The data fields on a record in the input ASCII file are in either a fixed format or variable format. Fixed format records contain data values of specified length beginning in fixed locations in the record with no delimiter separating the values. Variable format records contain data values without a specified length and not necessarily in the same location in each record, and these records include a delimiter to separate the values for fields.

A control file is created as an interface between the input ASCII file and the Clintrial database table for the batch-loading. The control file interprets the organization and format of data in the input ASCII file and provides the instructions on the loading process.

All batch-loaded data are automatically loaded into the Clintrial database's update tables. The data must pass screening before the data can be edited, coded, validated, and merged to the study data tables. Screening is the process that includes updating internal system items to uniquely identify the records, grouping the records into observations (not used in JHS), and applying data checks to data that has been batch loaded into the update table. The data checks confirm that subjects are enrolled and that mandatory items are defined, and they apply the range checks (lower and upper limits) and checklist tests.
(checklists not currently used in JHS) for an item. Records that have been batch loaded and screened in Manage appear identical to those records entered interactively in Enter.

Once data have passed screening, the data are ready to be edited, coded, validated, and merged. You can view the results of batch-loading in the SQL*Load Log from the Reports menu.

3.2.2 Preparing Data for Batch Loading

3.2.2.1 Creating a Control File

To create a control file, do as follows:

1. Select Load > Control File > New from the Manage window.
2. In the Open dialog box, select the panel for which you are creating the control file and the file format of the input ASCII file (fixed format or variable format).
3. Click OK to continue. The default version of the control file is displayed in the Control File window.
4. You can optionally edit the default control file at this time. See edit instructions below.
5. To save the control file, select File > Save or File > Save As to write the control file to the default C:\CT42 Clintrial directory or a directory of your choice. By default, the file name is panelname.ctl.
6. To close the Control File window, select File > Close or click on the window’s X button.

To edit the default control file, do as follows:

1. If the Control File window is not opened, select Load > Control File > Edit to open the control file for editing. Indicate the directory location and file name in the Open dialog box. Click on Open to open the control file in the Control File window.
2. Edit the control file to correspond to the input ASCII file format, as follows:
   a. Reorder items in the control file to match the order of values in the input ASCII file.
   b. Delete items for which the input ASCII file does not contain values.
   c. Add conversion instructions, such as instructions to convert date formats.
   d. The control file must specify the character used to indicate character strings in the input ASCII file. Change the ENCLOSED By clause to contain this character. Default is the double quotation mark, for example, OPTIONALLY ENCLOSED BY ‘ “ ’.
   e. For a variable format control file, change the default delimiter ‘@’ to the character that is used as a field delimiter in the input ASCII file, for example, FIELDS TERMINATED BY ‘;’ for a comma-separated file (.cvs).
   f. For a fixed format control file, change an item fixed size if needed.
   g. By default, a control file includes the line TRAILING NULLCOLS to indicate that, if not enough values are supplied for a record in the input ASCII file, items in the panel will be given the value of Null when the record is batch loaded.
   h. For probably all date fields, you will want to change the date format of the item. For example, specify the date format as DATE “MM/DD/YYYY” if the input ASCII file contains the date 10/03/2000 (has not yet been tested in JHS).
   i. For items of data type NUMBER or DATE, the default control file contains a NULLIF clause. The NULLIF clause in the default control file specifies an item as Null if the value in the input ASCII file is blank. Specify another value if the input ASCII file contains a value other than blank for Null, for example, a period (.)
   j. Items of data type TEXT contain an LTRIM clause to trim leading blanks and a RTRIM clause to trim trailing blanks.
3. Select File > Save or File > Save As to save the edited control file.
4. Select File > Close or click on the window’s X button to close the Control File window.

3.2.2.2 Loading the Data

To batch load data requires that the Oracle SQL*Loader is installed on the computer (use the 32-bit version). Consult Oracle SQL*Loader documentation for more detailed information on loading data.
It is recommended that you check a batch-load of a sampling of records in the input ASCII file to ensure that positions and formats of fields in the input ASCII file match the corresponding control file.

To batch-load data, do as follows:

1. Select **Load > Load Data** from the Manage window. The Batch SQL Loader dialog box opens.
2. In the dialog box, specify the names and locations of the control file for **Control File** and the input ASCII file for **Data**. Clintrial saves the files specified in this dialog box as defaults for the next session, but you can change these defaults if needed. You can also specify names and locations of files created by the batch-load process: the **Log file**, the **Bad file**, and the **Discard file**. The Log file is a report file of the batch-loading process. The Bad file lists records that were rejected. The Discard file lists records that did not meet the selection criteria for batch loading.
3. If you click **Advanced** in the Batch SQL Loader dialog box, the Advanced Batch Loader Options dialog box opens. You can select addition options as needed such as Records to Skip, Records to Load, Rows per Commit, Maximum Errors, Maximum Discards, and Maximum Bind Array. In most cases, you will probably use the Clintrial defaults. Click OK to continue.
4. From the Batch SQL Loader dialog box, click **Load** to batch load the data into an update table. Click OK to close message that job was submitted. The Batch SQL Loader dialog box closes after the job has run.
5. From the Manage window, select **Reports > SQL*Load Log** to view the results of the job run. The Open dialog box opens. Select the path and name of the load log file, then click Open. The Oracle Batch Log window opens. For information on the log's entries, see your Oracle documentation. You can print the report from **File > Print**. Close the Oracle Batch Log window from **File > Close** or from the window's X button to return to the Manage window.

### 3.2.2.3 Screening Batch-Loaded Data

You screen records after data are batch loaded into an update table. Screening combines the following processes running concurrently:

- Applies data checks to record data
- Updates the system items
- Groups records into observations as needed (not used in JHS)

The data checks include the same checks applied during interactive data-entry. Records that have been successfully batch-loaded and screened appear identical to records that were entered interactively.

You can only screen records whose **record status** is Unscreened (3) or Screening Error (-3). Records that pass screening are assigned the status Verified (1). Records that fail screening are assigned the status Screening Error (-3).

To screen batch-loaded data, do as follows:

1. Select **Load > Screen** from the Manage window. The Screen dialog box opens.
2. In the Screen dialog box, select the panel(s) from **Panels** that you want to screen. To screen records, check **Release for Validation**. To override data-entry checks on the data, check **Override Checks**. To select records for screening by using a SQL restriction, click **SQL**. To screen data as a batch process, check **Submit Batch**.
3. Click **OK** to screen the records. Click **OK** in the message box at the completion of the screening process.
4. To view the results of screening in Screen Log, select **Reports > Screen Log > View** in the Manage window. The Screen Log is a cumulative report that describes the results of the screening process with entries for each panel that was screened. You can print the Screen Log report from **File > Print** or save from **File > Save As**. Close the Screen Log window from **File > Close** or from the window's X button to return to the Manage window.
Once a record passes screening, it can be edited, coded, validated, and merged.

3.3 Coding Data – not available at this time

3.3.1 Overview

3.3.2 Coding Thesaurus

3.3.3 Coding Techniques – Automatic, Interactive

3.3.4 Items To Be Coded

3.4 Validating and Merging Data

3.4.1 Overview

Validation is a data cleaning process that checks the integrity of study data in the update tables by finding errors and data inconsistencies. Records must pass validation before they can be merged to the data tables.

Merging is the process of moving data that has passed validation from the update tables to the data tables.

3.4.2 Validating Data

During validation, a validation procedure is run against the data in the update tables. A validation procedure is a PL/SQL procedure that is built automatically from derivations and rules. Derivations and rules are specified during the design of the DMS for a protocol panel. Derivations calculate derived values in the records being validated. Rules check that the data meet certain requirements of the study protocol. There is one validation procedure for each panel.

Records in the update tables must pass validation before they can be merged (moved) to the data tables.

You can view the results of the validation process in the Validation Log. An evaluation of a rule to False during validation also generates an entry in the Error Log. You can then review and edit the record from the Error Log.

To validate data, do as follows:

1. You can select records for validation either by panel (the Clintrial default) or by study page (the JHS DMS preference). To validate records by study page, set the Manage user preference SELECT_BY_PAGE to Yes from File > Preferences in the Manage window.
2. Select Manage > Validate in the Manage window. The Set Study Book dialog box may open if a study book has not been selected (go to 3), otherwise the Validation dialog box opens (go to 4).
3. In the Set Study Book dialog box, select the study book for the data that you want to validate. Click OK to continue. The Validation dialog box opens.
4. To validate records by study page, do as follows:
   a. From the Page List drop-down list, select the page list that you want to use. You can create a new list from List > New List or edit an existing list from List > Edit Page List using the List Wizard.
   b. Select either All pages or Selected pages to validate. Select the specific pages to validate from the list for Selected pages.
   c. Optionally you can restrict the data included in the validation as follows:
      1) For the date and time that records were last modified, enter a Date and Time Range.
      2) For record status, select a Status.
3) For flags present, select one or more Flags.
4) For notes present, select one or more Notes.
5) For a SQL restriction, select Edit > SQL Restriction.

d. Check the type of database table(s) you want to validate in Table(s): UPDATE, DATA, or both.
e. If you are running a test validation, clear the Release for Merge check box. Otherwise check Release for Merge.
f. To run the validation as a batch process, check Submit Batch. Otherwise the validation runs interactively.
g. Select File > Run. Click OK in the message box at the completion of the validation run. You return to the Validation dialog box.
h. Select Reports > Validation Log to view the results of validation in the Validation Log. You can print the Validation Log from File > Print or save from File > Save As. Close the Validation Log window from File > Close or from the window’s X button.
i. Close the Validation dialog box at the completion of the validation process from File > Close or from the window’s X button.

3.4.3 Merging Data

Once data have been validated, then data can be merged (moved) from the update tables to the data tables where the clean data are stored.

To merge records, do as follows:

1. You can select records for merging either by panel (the Clintrial default) or by study page (the JHS DMS preference). To merge records by study page, set the Manage user preference SELECT_BY_PAGE to Yes from File > Preferences in the Manage window.
2. Select Manage > Merge in the Manage window. The Set Study Book dialog box may open if a study book has not been selected (go to 3), otherwise the Merge dialog box opens (go to 4).
3. In the Set Study Book dialog box, select the study book for the data that you want to validate. Click OK to continue. The Merge dialog box opens.
4. To merge records by study page, do as follows:
   a. From the Page List drop-down list, select the page list that you want to use. You can create a new list from List > New List or edit an existing list from List > Edit Page List using the List Wizard.
   b. Select either All pages or Selected pages to merge. Select the specific pages to merge from the list for Selected pages.
   c. Optionally you can restrict the data included in the merge as follows:
      1) For the date and time that records were last modified, enter a Date and Time Range.
      2) For record status, select a Status.
      3) For flags present, select one or more Flags.
      4) For notes present, select one or more Notes.
      5) For a SQL restriction, select Edit > SQL Restriction.
   d. To validate the panels of the selected study pages before merging, if not done in Manage > Validate, check Validate First.
   e. To run the merge as a batch process, check Submit Batch. Otherwise merge runs interactively.
   f. Select File > Run. Click OK in the message box at the completion of the merge run. You return to the Merge dialog box.
   g. Select Reports > Merge Log to view the results of the merge in the Merge Log. For information on any errors, see the Help menu for the Manage module on Validation and Merging: Error actions. You can print the Merge Log from File > Print or save from File > Save As. Close the Merge Log window from File > Close or from the window’s X button.
   h. Close the Merge dialog box at the completion of the merge from File > Close or from the window’s X button.
3.5  Global Data Changes and Deletions

3.5.1  Introduction

Global change is the process of changing one or more values in multiple records simultaneously. You can make global changes to individual or multiple panels, and to records in the update table, data table, or both. You cannot directly change any derived item values.

Global deletion is the process of deleting multiple records simultaneously. You can make global deletions to individual or multiple panels, and to records in the update table, data table, or both. You can view the results of global deletion in the Global Delete Log.

Global change and global deletion are powerful processes that alter records irrevocably. Because of this, before you save any global changes or deletions, you should preview the results of the global change or deletion process to ensure that the desired change is made or that the correct records have been selected for deletion. If the preview results are correct, you can then run the global change or deletion process and save the results.

If you want to change or delete enrollment data for study subjects, that is, records in the enrollment panel, you must perform a global change or global deletion. You cannot change or delete enrollment data using any other method. To change or delete subject item values or any subject-related context items, you must select only the enrollment panel. If you change or delete the subject item, when the global change is successful, records are changed or deleted in all panels in which the subject item is stored. To change other context item values, select all the panels you want to change, excluding the enrollment panel and any type 0 panels (non-subject data).

You can view the results of global change in the Global Change Log. Errors that occur during global change are recorded in the Error Log with the error types of GLOBCHG.

You can view the results of global deletion in the Global Delete Log. Errors that occur during global deletion are recorded in the Error Log with the error types of GLOBDEL.

3.5.2  Global Change

To make a global change, do as follows:

1. Select Manage > Global Change in the Manage window. The Select dialog box opens.
2. In the Select dialog box, select the panels and tables whose records you want to change. When you click OK, the Global Change dialog box opens.
3. In the Global Change dialog box, do as follows:
   a. Select the subjects you want to make changes to, except for type 0 panels. To select the subjects, do one of the following:
      1) For all subjects, click All Subjects.
      2) For individual subjects, click Selected Subjects. Select the subjects you want to change.
   b. Under Restrict Data, select records to change as follows:
      1) For the presence of flags, select one or more Flags.
      2) For the presence of notes, select one or more Notes.
      3) For a SQL restriction, click the SQL Restriction box.
   c. To override data-entry checks on the new values, check Override Checks.
   d. To run the changes as a batch process, check Submit Batch. Otherwise global changes are done interactively.
   e. Enter the new values for the items you want to change in the Change To field. To specify global change values, note the following:
      1) The new value must match the database format of the item.
      2) For items with data type TEXT, you must enclose the new value in single quotes.
3) The new value can be a constant, or a calculated value that can refer to other items in the panel.
4) To specify a calculated value, enter a valid SQL UPDATE statement. The SQL statement can contain any valid Oracle function or operator.
f. To preview your changes before running them (recommended), select View > Preview.
i. To run the changes, select File > Run. Click OK in the message box at the completion of the global change run. You return to the Global Change dialog box.
g. Select Reports > Global Change Log to view the results of a global change in the Global Change Log. You can print the Global Change Log from File > Print or save from File > Save As. Close the Global Change Log window from File > Close or from the window’s X button to return to the Manage window.
h. Close the Global Change dialog box at the completion of the global change from File > Close or from the window’s X button.

3.5.3 Global Deletion

To make a global deletion, do as follows:

1. Select Manage > Global Delete in the Manage window. The Select dialog box opens.
2. In the Select dialog box, select the panels and tables whose records you want to delete. When you click OK, the Global Delete dialog box opens.
3. In the Global Delete dialog box, do as follows:
   a. Select the subjects you want to delete, except for type 0 panels. To select the subjects, do one of the following:
      1) For all subjects, click All Subjects.
      2) For individual subjects, click Selected Subjects. Select the subjects you want to delete.
   b. Under Restrict Data, select records to delete as follows:
      1) For the presence of flags, select one or more Flags.
      2) For the presence of notes, select one or more Notes.
      3) For a SQL restriction, click the SQL Restriction box.
   c. To run the deletions as a batch process, check Submit Batch. Otherwise global deletions are done interactively.
   d. To preview your deletions before running them (recommended), select View > Preview.
   j. To run the deletions, select File > Run. Click OK in the message box at the completion of the global deletion run. You return to the Global Delete dialog box.
   e. Select Reports > Global Delete Log to view the results of a global deletion in the Global Delete Log. You can print the Global Delete Log from File > Print or save from File > Save As. Close the Global Delete Log window from File > Close or from the window’s X button to return to the Manage window.
   f. Close the Global Delete dialog box at the completion of the global deletion from File > Close or from the window’s X button.

3.6 Logs and Reports

Clintrial contains twelve logs and reports in the Manage module that show the results of various data management processes. Logs and reports can be viewed online, printed, and saved to a file.

No JHS DMS custom logs and reports are available at this time.

The Manage logs and reports are as follows:

Audit History Report – a report that shows the history of changes to the audit start point for all audited panels, including the current and past audit start points for each panel, and the dates at which the audit start points became effective.
Audit Notes Report – a report that shows the changes made to notes attached to records in one panel. It does not show deletions of notes attached to clinical data. For a note to appear in the report, the record to which it is attached must itself be eligible for auditing.

Audit Records Report – a report that shows all changes and deletions made to a panel's records after the audit start point has been reached.

Automatic Coding Log - a cumulative report that describes the results of the automatic coding process. Contains entries for each panel that was coded automatically.

Coded Item Report - a report that provides information about items that were coded interactively for a panel, including the verbatim text, thesaurus term, and code applied for each item.

Error Log - a cumulative log of errors that occurred during screening, validation, merging, global change, and global deletion. There is one Error Log per protocol. Errors are displayed in ascending order by panel and subject item. Each row represents a record in the panel. When viewing the Error Log, you can double-click a record to open that record for editing in a study page.

Global Change Log - a cumulative report that describes the results of global change processes. Contains entries for each panel and table that was submitted for global change. When you change enrollment records, this log shows only one record modified, however, records in every panel in which that subject item is stored are also modified.

Global Delete Log - a cumulative report that describes the results of global deletion processes. Contains entries for each panel and table that was submitted for global deletion. When you delete enrollment records, this log shows only one record deleted, however, records in every panel in which that subject item is stored are also deleted.

Merge Log - a cumulative report that describes the results of merging processes. Contains entries for each panel that was submitted for merging.

Screen Log - a cumulative report that describes the results of the screening process after a batch-load. Contains entries for each panel that was screened.

SQL Load Log – a report that displays the results of batch-loading.

Validation Log - a cumulative report that describes the results of the validation process. Contains entries for each panel and table that was validated.

To view a log or report, select View from the Reports menu for a log. It takes several minutes for a log to display following notification of completion of a batch process. If an open log window is empty, wait another minute and then select File > Refresh.

Logs can be filtered to show only specific rows. In the log window, select View > Filter to open the Specify Filter dialog box. Click on Help for instructions. Click on OK to return to the log window.

Logs can be sorted according to criteria you define. In the log window, select View > Sort to open the Specify Sort Columns dialog box. Click on Help for instructions in sorting data. Click on OK to return to the log window.

When viewing a log or report, you can navigate between its pages by using the View > First Page, View > Prior Page, View > Next Page, and View > Last Page.

You can purge logs of data at any time. When you purge a log, you can purge all of its records (Purge All) or only selected records (Purge Selected) from the Reports menu for the log.
3.7 Closure Checks

Not available at this time.
This page is intentionally left blank.
4.0  PROGRAMMER GUIDE TO RETRIEVING DATA

4.1  Overview

SAS Version 8 is being used for retrieval of study data entered in the JHS DMS and stored in the Oracle database. SAS Version 8 can access the Oracle database directly using the new SAS/ACCESS LIBNAME statement that can take full advantage of SAS Version 7 and Version 8 enhancements.

The SAS data retrieval program and retrieval process described here are for the second release of the JHS_COHORT protocol distributed on December 14, 2000. The SAS retrieval program will require modification after each protocol release for any new form/version.

Earlier versions of this SAS retrieval program used the SAS/ACCESS to Oracle interface to read the Oracle data tables. Due to retrieval constraints using the SAS/ACCESS interface -- limited to SAS Version 6 naming conventions and restricted to text value lengths no longer than 200 characters -- the program was rewritten to use the new SAS/ACCESS LIBNAME statement to read the Oracle data tables. This enables the use of 32-byte names for SAS variables and enables read/write of character data up to 32,767 bytes using a DBMAX_TEXT option. And, now there is no creation of access and view descriptor files as an intermediate step to creation of SAS analysis datasets.

As an alternative to the SAS data retrieval procedure, a description of the Clintrial Retrieve Query By Form (QBF) procedure is also provided.

4.2  SAS Retrieval for Custom Reports

Not available at this time. Development will be similar to SAS retrieval for data analysis.

4.3  SAS Retrieval for Data Analysis

4.3.1  Overview

The SAS data retrieval program reads data directly from the Oracle data tables with the SAS/ACCESS LIBNAME statement and creates output SAS analysis datasets, one dataset per form/version.

Data integrity and security are maintained in this process. The SAS/ACCESS LIBNAME statement requires entry of Oracle username, password, database alias, and protocol name. A parameter specifies access to the Oracle data tables as read-only. The JHSCC must identify allowable users for data retrieval, and the Database Administrator must provide adequate Oracle access rights for these users. These rights must be similar to the Oracle SYSTEM user account for access to data entered by any user. The SAS retrieval program delivered to the JHSCC will include the SYSTEM user account as default.

4.3.2  Contents of SAS Retrieval Program

The SAS retrieval program contains the following sections:

1. Documentation block providing a description of the program.
2. SAS environment options.
3. Initialization of program macro variables.
4. Initialization of macro variables for Oracle access.
5. LIBNAME statements for input Oracle data tables and output SAS analysis datasets.
6. Program title and footnote statements.
7. %INCLUDE statement for PROC FORMAT code.
8. Macros:
a. RETRV reads Oracle data tables and creates output SAS analysis datasets, with conversion of DATETIME variables to SAS DATE variables and with a %INCLUDE statement for FORMAT and LABEL statements by form/version.
b. RENAME provides original and temporary variable names for a list of variables to convert from DATETIME to SAS DATE format.
c. COUNT counts the number of variables in a list for renaming.

9. Macro calls to RETRV for each form/version. Parameter PAGES is the list of page sections (likewise, data tables) that comprise a single form, and parameter DVARS is the list of DATETIME variables to convert to SAS DATE variables.

4.3.3 Setup of the SAS Retrieval Program

The current version of the SAS retrieval program was developed in SAS Version 8.1 that was installed as a standalone program on a workstation connected to the JHS server containing the Oracle database. This SAS retrieval program does not need to be called from within Clintrial or the JHS DMS.

Steps to set up the SAS retrieval program:

1. Install the SAS System software, Version 8 or later, according to your site’s software installation policy.
2. Copy the SAS retrieval program file and accompanying files (%INCLUDE source code) to a directory on your workstation.
3. Edit the SAS retrieval program as follows:
   a. Modify the ‘outds’ macro variable to specify the LIBREF name of the LIBNAME statement for the output SAS analysis datasets and modify the corresponding LIBNAME statement with the directory location of the output SAS analysis datasets. The SAS retrieval program delivered to the JHSCC includes the LIBNAME statement as used at the UNC-CSCC.
   b. Enter the Oracle access information for your site (macro variables ‘username’, ‘userpw’, ‘database’, and ‘protocol’). The SAS retrieval program delivered to the JHSCC includes the SYSTEM user account information, the database alias ORC0, and the protocol name JHS_COHORT.
   c. Modify the ‘home’ and ‘byformcd’ macro variables to specify the directory locations of the %INCLUDE source code. The program delivered to the JHSCC includes the directory locations used at the UNC-CSCC.

4.3.4 Generation of %INCLUDE Source Code for Formats and Variable Labels

A process was established to generate PROC FORMAT statements and FORMAT and LABEL statements from information in the database to include in the SAS retrieval program. A single text file is created of the PROC FORMAT statements for all codelists in the database, and individual text files for each form/version are created of FORMAT and LABEL statements for items in the protocol. In addition, a list of DATETIME variables is generated to update the RETRV macro parameter DVARS for each form/version to convert DATETIME variables to SAS DATE variables.

The steps to generate source code for the SAS retrieval program are as follows:

1. Generate the PROC FORMAT code of all codelists in the database from a Clintrial Retrieve module query. To create a format library text file, do as follows:
   a. Select any query type from File > New Query from the Retrieve browser (for example, select By SQL).
   b. In the query dialog box (for example, Query By SQL dialog box), do as follows:
      1) Enter a query. For example, for Query By SQL, enter SQL text ‘select * from JHS_COHORT.ABBA1_ALL;’. Entry of a valid query is required to get to the next dialog box to generate the PROC FORMAT code.
      2) Select Results > To SAS Data File.
      3) Select File > Run Query.
c. Now in the Create a SAS File dialog box, do as follows:
   1) Check option **Generate SAS Format Library**. You do not need to generate a SAS data file.
   2) Click on **Browse** to select a directory path location and to enter a file name (without extension) for the resultant code. The directory path and file name must not contain embedded periods (.), otherwise Clintrial will truncate the path or name at the first period. The output text file will have extension FMT (for example, FrmtlibV1-2.fmt).
   3) Click **OK** to continue.
   4) Close the open windows and exit Clintrial.

   d. To preserve the original version of FrmtlibV1-2.fmt, make a duplicate copy of the file to modify for the SAS retrieval program (for example, JHSRetrV1-2PrFormat.sas).

   e. Edit text file JHSRetrV1-2PrFormat.sas to replace single and double quotation marks embedded in the value text string with two single quotation marks. It is not required to remove statements for forms or items not in the current protocol.

   f. Include this text file in a `%INCLUDE` statement in the SAS retrieval program.

   g. Special note: Clintrial uses the following conventions for SAS format names:
      1) 8-character maximum.
      2) Prefix ‘$’ if code is TEXT data type.
      3) The 6-character codelist SAS name assigned in Design.
      4) Suffix ‘V’ if decoding to values or ‘S’ if decoding to short label or ‘L’ if decoding to long label. In JHS, we decode to values.

2. Run the following three SQL SELECT commands (in file JHSRetrV1-2Selects.sql) from a SQL command window to create FORMAT statements and LABEL statements for all relevant items in the current protocol. You will need to run these SQL commands using an Oracle user account with access rights like user SYSTEM. The PLSQL Developer software is used at the UNC-CSCC.

   For FORMAT statements of character codes:
   ```sql
   SELECT distinct 'format '|a.item_name||'$'||b.sasname||'V. ;' item_code
   FROM ctsdd.item a, ctscodes.code_index b
   WHERE a.protocol='JHS_COHORT'
   and b.codetype='TEXT'
   and a.codename is not null
   and a.codename=b.codelist
   ORDER BY item_code ;
   ```

   For FORMAT statements of numeric codes:
   ```sql
   SELECT distinct 'format '|a.item_name||b.sasname||'V. ;' item_code
   FROM ctsdd.item a, ctscodes.code_index b
   WHERE a.protocol='JHS_COHORT'
   and b.codetype='FIXED'
   and a.codename is not null
   and a.codename=b.codelist
   ORDER BY item_code ;
   ```

   For LABEL statements:
   ```sql
   (SAS V8 allows up to 40 characters for variable label text. A blank is added as the last character of the label text to handle cases where DESCRIP is null and needs a blank space between double quotation marks as label text.)
   SELECT distinct 'label '|substr(descrip,1,39)||' ";'
   FROM ctsdd.item
   WHERE protocol='JHS_COHORT'
   ORDER BY item_label ;
   ```

   a. Run the SELECT commands. For example, in the PLSQL Developer software, select File > Open > Command File, enter the SELECT commands, and then choose Session > Execute.
Select all the output statements generated (Edit > Select All) and copy (Edit > Copy) to a single text file (for example, Parse_TextV1-2.txt).

b. Edit text file Parse_TextV1-2.txt as follows:
   1) Modify any variable labels with two consecutive double quotation marks (""") indicating no label text by inserting a blank (" "), otherwise a single quotation mark prints as the label text.
   2) Replace embedded double quotation marks in the label text with single quotation marks.
   3) Remove semicolons embedded in label text.
   4) It is not necessary to remove extra lines of text and underscores generated by a SELECT command run, such as the header associated with a page break.

c. Continue with step 3.

3. Run the SAS program Parse_TextV1-2.sas to select FORMAT and LABEL statements by form/version from input text file Parse_TextV1-2.txt (created in step 2) and create individual output text files for each form/version. Currently this SAS program adds comment delimiters around the FORMAT statements in the output text files so that codes and not format values are stored in the output analysis SAS datasets.
   a. Check each output text file and remove any unwanted text. For example, remove any lines that do not begin with 'format' or 'label' or do not contain the comment delimiters.
   b. Include the individual output text files in a %INCLUDE statement in the SAS retrieval program. A single %INCLUDE statement contains the form/version file name as a macro variable.
   c. Special note for FORMAT statements: See step 1 for Clintrial’s naming conventions of SAS format names.
   d. Special notes for LABEL statements: LABEL statements for CONTEXT panel items (key field items) are hardcoded in the SAS retrieval program. A label text can contain up to 40 characters in SAS Version 8.

4. Run the following SQL SELECT command (in file ItemdateV1-2.sql) to list all DATETIME variables in the current protocol to convert to SAS DATE variables in the SAS retrieval program. You will need to run the SQL command using an Oracle user account with access rights like user SYSTEM. In the SAS retrieval program, add the variable names to the RETRV macro parameter DVARS by form/version.

   ```sql
   SELECT item_name
   FROM ctsdd.item
   WHERE protocol='JHS_COHORT' and dtype in('DATE','DATETIME')
   ORDER BY item_name;
   ```

4.3.5 Special Notes on the Current Version of the SAS Retrieval

1. The program contains retrieval code for forms included in the JHS_COHORT protocol as of December 14, 2000.
2. The program retrieves data field values only and does not include retrieval of flags and notes.
3. The program includes LABEL statements with the label text from the Clintrial item descriptions used as screen prompts. The item descriptions were assigned when the item was created to accommodate screen design and to match form layout. It is recommended that the JHSCC staff review and update these variable labels for the SAS retrieval program to meet their analysis needs. Notes on the labels:
   a. Label text lengths are limited to 40 characters, so some labels are truncated.
   b. A label may be blank or abbreviated or the text of an instruction, as per the form layout.
   c. A label may be incorrect if a change was made to the item but was not made also to the item description. A screen prompt can revised directly on the page section, not requiring that the item description be changed as well.
4. The program includes codelist codes and values in a SAS FORMAT procedure and in FORMAT statements. The FORMAT statements currently are within comment delimiters so that the data values written to the output SAS analysis datasets are the codes and not the format values.
5. Clintrial’s DATE format is stored as a DATETIME format in the Oracle database. The SAS retrieval program converts DATETIME variables to SAS DATE variables using the SAS DATEPART function. Only study data dates are converted, not Clintrial-generated system dates.

6. Although the SAS retrieval program sets the YEARCUTOFF option to 1912 (a UNC-CSCC ARIC statistical programming rule), it can only interpret dates as retrieved from the Oracle database. Note the following year cutoff rule for Clintrial data entry (from Clintrial Help): “Years can be entered as two digits or four. When a two-digit year is entered, Clintrial stores numbers 00 to 49 as 21st century (2049) and numbers 50 to 99 as 20th century (1950).” The data entry personnel must be instructed to enter dates with a 4-digit year to ensure the correct century.

4.4 Clintrial Retrieve Query By Form (QBF)

4.4.1 Introduction

Clintrial Retrieve, one of the Clintrial core modules, can be used to access and extract data from the Clintrial database by creating and running queries. To access the Retrieve module, a user account must have the appropriate access rights assigned by the Clintrial Administrator.

Queries are created using the following four types of query tools:

- **Query By Form** - selecting fields and entering selection criteria directly on a study page (form). Requires familiarity with the study forms and with the data entry standards, but does not require familiarity with either SQL or with the structure of the Clintrial database.

- **Query By Panel** – defining detailed search criteria through use of SQL. Requires familiarity with panels and items within Clintrial and with simple SQL syntax.

- **Query By SQL** – creating SELECT and DESCRIBE statements. Requires familiarity with the structure of the Clintrial database and with SQL.

- **Ad Hoc Query** - creating subject record lists to retrieve data for those subjects. It does not require familiarity with SQL, but does require familiarity with the structure of the Clintrial database.

Query results can be sent to the screen, to an Oracle database table, or to a SAS data file. Then these data can be used in other applications to perform statistical analysis, create reports, or perform other tasks.

You can store the queries in a Query Library where it can be accessed at a later time. You can modify, copy, run, and delete saved queries.

Using the Custom menu in Retrieve and in other modules, a user can access and start up other applications to create reports from the study data. The user has access to the application from within Clintrial, but it executes outside of Clintrial.

4.4.2 Using Query By Form

Query By Form (QBF) is a query method that creates a query directly from the same online study pages used in Clintrial Enter for data entry. For the JHS DMS, a single study page is usually equivalent to one form. However in several cases, a JHS form was split into two study pages due to Clintrial design limitations, i.e., PACA parts 1 and 2, PDSA parts 1 and 2, PFHA parts 1 and 2, DISA parts 1 and 2, MHXA parts 1 and 2, MSRA parts 1 and 2, SSFA parts 1 and 2.

You can create a query from multiple study pages. The number of study pages available at a time is determined by the ENT_OPEN_PAGES preference for the Enter module that is set by the Clintrial administrator. For JHS data entry, the preference is set at 1 (allowable range is 1-10) to limit the number of open pages at one time by a single user account in Enter. Once data have been entered and verified,
set the ENT_OPEN_PAGES preference to at least 2 for the Retrieve sessions so that you can add multiple study pages to a query for the several JHS forms that are split into multiple study pages.

Below are the steps for using Query By Form. It is suggested to perform a separate query for each JHS form, repeating these steps for each form.

Assumptions are that you have logged into the Clintrial Retrieve module and have selected the correct protocol:

- Start the Clintrial Retrieve module from Start > Programs > Clintrial 4.2 > Retrieve. Login to Clintrial with a valid Clintrial user name, password, and database alias (ORC0 for JHS). You are now in the Clintrial Retrieve window.
- From the Retrieve window menu bar, select File > Set Protocol and protocol JHS_COHORT for retrieval of the baseline visit 1 data, if not automatically set at login.

The steps to use Query By Form are as follows:

1. **Start Query By Form.**
   
   From the Retrieve window menu bar, select **File > New Query > By Form (QBF)** to start Query By Form. The Select Page dialog box opens.

2. **Select study pages.**
   
   From the Select Page dialog box, select the study page(s) to include in the query. Study pages are added to a query one at a time. These study pages do not need to be in the same block (visit) or study book (INTERVIEW or EXAM).
   
   To select a study page, do as follows:
   a. Select a study book.
   b. Select a study page from the list, or type the study page name in the Page field.
   c. Click OK to continue. A Query By Form window opens, displaying the study page you selected.
   
   To open another study page, select **Edit > Select Additional Page** and repeat a-c above. If multiple study pages are open, you can move to another study page that is open using the commands in the Window menu. If an additional page is selected from the Edit menu that is already open, a new copy of the study page opens.

3. **Select fields.**
   
   For the study page open in the Query By Form window, select either specific fields or all fields for the study page. The selected fields are highlighted on the study page.
   
   To select or deselect all fields on the study page, select **Edit > Select All**.
   
   To select or deselect a specific field, place the cursor in the field that you want to select or deselect using the Tab key or the mouse and then choose **Edit > Select Item**.

4. **Enter criteria in fields to specify a subset of data to retrieve (optional).**
   
   If you enter selection criteria for a field, you do not also have to retrieve values for that field when you run the query. Selecting fields and entering selection criteria are separate tasks.
   
   To enter selection criteria for the study page open in the Query By Form window, do the following:
   a. Place the cursor in the field for which you want to enter selection criteria using the Tab key or the mouse.
b. Enter the selection criteria using one of the following methods:
   1) Enter an exact valid value. For a text field, enter the value without quotation marks. For a numeric value, enter a numeric value or function without quotation marks. For a date field, enter a date in a valid date format without quotation marks.
   2) Enter a value pattern as an operator and a valid value. No quotation marks are needed for text or numeric types, but they are required for date types.
   3) Select a code from the codelist, and optionally add an operator.

   c. To enter a selection criteria for another field, repeat a and b.

5. Create a sort order of retrieved records (optional).

You create a sorting order for the retrieved records by field values. The default sort order for a field is None. You can specify sort orders for more than one field. Clintrial sorts the results according to the tab order of the fields.

To sort the query results for the study page open in the Query By Form window, do as follows:
   a. Place the cursor in the field whose values you want to sort.
   b. Select Edit > Sort to open the Sort Field dialog box.
   c. Select sort order Ascending, Descending, or None, then click OK to continue.

   To remove the sort order for a field, do a-c above and select None.

To change the field sort order, do one of the following:
   a. Select Results > To Window to display the results on the screen, then run the query from File > Run Query. When the results are displayed on your screen, select View > Sort to sort the displayed records.
   b. Select File > Convert to SQL to convert the query to SQL code, then change the SQL syntax to reflect the order you want.

6. Create flag or note restrictions (optional).

To create a flag or note restriction for the study page open in the Query By Form window, do as follows:
   a. Select Edit > Flags/Notes Restrictions.
   b. Select the flag or note category and the flag or note name from the drop down list.
   c. Specify the flag or note level.
   d. Specify the page to which you want the flag or note to be attached. Note for the JHS DMS, the page number is displayed for the open study page and the field is disabled for entry.
   e. If you are creating a restriction at the Item level, specify the item to which you want the flag or note to be attached.
   f. Click Add. Clintrial Retrieve adds the flag or note restriction to the Selection box.
   g. Select whether to retrieve records if the flag or note is present or absent from the drop down list.
   h. To create multiple flag or note restrictions, repeat b-g. A logical operator field appears in the Selection box. Select the flag or note connector from the drop down list.

To remove a flag or note restriction, do as follows:
   a. Select the flag or note restriction to remove by clicking anywhere within the restriction in the Selection box.
   b. Click Delete.

7. Display the query in SQL format (optional).

You can display the SQL for the current query in Query By Form from File > Convert to SQL to review a single page query, to review a multi-page query as a whole, or to perform tasks for which you must use SQL. You can display a query in SQL at any time and still return to the Query By Form page(s) if you do not alter the SQL. However, if you alter the SQL in the Query By SQL window, you
should not return to the Query By Form page(s). Any changes you make to the SQL cannot display in the Query By Form page(s).

8. Run the query to retrieve the query results, and send the results to various locations in various export formats.

To run a query in the Query By Form window, do as follows:
   a. Select the destination for the query results from the Results menu. Options are To Window, To Oracle table, or To SAS Data file.
   b. Select File > Run Query.

After the query runs, your results destination does one of the following:
   a. To Window - displays the results in a Query By Form Results window.
   b. To Oracle table – opens the Results to Oracle Table dialog box.
   c. To SAS Data file – opens the Create a SAS File dialog box.

See the section on saving results to a SAS data file below for details on creating an output ASCII file (.DAT) of the study data retrieved from the query and a SAS source code file (.SAS) with the input statement containing the variable names and formats to read the ASCII data file.

9. Print the query.

Select File > Printer Setup to specify which local or network printer to use. Depending on your printer, you can also adjust certain printer defaults like page orientation, paper size, and print resolution. Consult your printer’s documentation for more information.

To print a report or window from the Query By Form window, do as follows:
   a. Select File > Print. At any time the Print command is not available for a displayed window, then that window does not have print capability.
   b. The Print Options dialog box opens. Accept default settings or modify any of the values as needed.
   c. Click OK to print.

10. Save the query to the Query Library for later use by you or other users (optional).

To save a query in the Query By Form window, do as follows:
   a. Select File > Save Query As.
      1) If you have previously saved this query, Clintrial Retrieve saves the query to the same query name automatically.
      2) If you have not previously saved this query, the Save Query As dialog box opens.
   b. In the Save Query As dialog box, do as follows:
      1) If you are saving a Query By SQL, select the protocol under which you want to save the query.
      2) Enter the query name
      3) Enter a description for the query.
      4) If you want the security access type for the query to be Public, check Public Query.
      5) Click OK.

To access the saved queries in the Query Library, select File > Query Library from the Query By Form window.

4.4.3 Saving Results to a SAS Data File

Query results can be saved to a SAS data file from the Query By Form window in one of two ways: save directly to a SAS data file without display, or display and then save to a SAS data file.
To run and save the query results directly to an SAS data file (does not display results), do as follows:

1. From the Query By Form window, select **Results > To SAS Data file** from the menu.
2. Create or select the query you want to run either for selected items (place cursor on item and then select **Edit > Select Item**) or for all items (select **Edit > Select All**).
3. Select **File > Run Query** to run the query and which opens the Create a SAS Data File dialog box.
4. From the Create a SAS Data File dialog box, to save the query results to a SAS data file, do:
   a. Specify path, file name, label, and record length for the SAS data file. Note that path C:\CT42 is the default.
   b. To create a PROC FORMAT for this data file (optional), check Make PROC FORMAT.
   c. Click OK. Clintrial Retrieve displays a confirmation message indicating where the query results are stored; click OK.

To run and display the query and then save the results to a SAS data file:

1. From the Query By Form window, run the query in **File > Run Query** which sends the results to a Query By Form Results window.
2. From the Query By Form Results window, select **File > Save Results As**. The Save Results As dialog box opens.
3. In the Save Results As dialog box, select SAS Data Files [.SAS] from the File Format drop down list. The file name in the File Name field changes to *.SAS, and the SAS fields at the bottom of the dialog box become active. Then, do:
   a. Specify the path, file name, label, and record length for the SAS data file. Note that path C:\CT42 is the default.
   b. To create a PROC FORMAT for this data file (optional), check Make PROC FORMAT.
   c. Click OK. Clintrial Retrieve displays a confirmation message indicating where the query results are stored; click OK.

4.4.4 Setup and Run the SAS Data

If you have saved the query results to a SAS data file, then you have the following two or three text files in the directory that you chose:

1. SAS source code file (.SAS) with a data step that includes an INFILE statement with the location and name of the ASCII data file, an INPUT statement with valid variable names and formats, LABEL statements for the variables (the prompt used in the data entry window), and optionally FORMAT statements for the variables with codelists.
2. ASCII file of SAS data (.DAT) from the query that corresponds to the SAS source code INPUT statement.
3. Optionally, PROC FORMAT code file (.FMT) with the VALUE statements for all the codelists attached to the variables in the query.

To setup a SAS program using these files, do the following:

1. Optionally insert the PROC FORMAT code file into the SAS source code file either directly or with a %INCLUDE statement.
2. Add additional SAS statements to the SAS source code file either to save the data to a permanent SAS dataset, to create a report, or to run data analysis.

You can now run the final SAS source code file in SAS. Consult your local SAS support personnel for information on how to run SAS at your site.
This page is intentionally left blank.
5.0 ADMINISTRATOR GUIDE

5.1 Data Entry Workstation Setup

Setting year format for dates

The format in which dates are entered and displayed in Clintrial is determined by the Window’s date setting. Set the date format (a regional setting) to a four-digit year format (mm/dd/yyyy).

In Clintrial data entry, enter four-digit years for dates to ensure the correct century. If a two-digit year is entered, Clintrial interprets the year as follows:

• 00 through 49 as the 2000’s
• 50 through 99 as the 1900’s

Creating a desktop Enter shortcut icon

To put a shortcut on the desktop, do as follows:
1. In Start > Programs > Clintrial 4.2, right-click on Clintrial Enter and left-click Create Shortcut.
2. Holding down the left mouse button, drag the new shortcut icon, named Clintrial Enter (2), from Start > Programs > Clintrial 4.2 onto the desktop.
3. To rename the shortcut, right-click the shortcut and left-click Rename. Type the new name, and press Enter.
4. Double-click the shortcut icon to start the Clintrial Enter module.

To change any settings for the shortcut, right-click the shortcut and then left-click Properties.

To delete a shortcut, drag the shortcut to the Recycle Bin. The original item still exists on the disk.

Screen resolution and window size

The screen resolution and window size for data entry must be set the same as the setting used during the development of the JHS DMS. The settings are as follow:

• Set the screen resolution to 800 by 600 pixels in Start > Settings > Control Panel > Display. Click on the Settings tab. Under Screen area, click on the left or right of the arrow to get this resolution.
• Set the window size to Maximum. Click the middle windows button on the top right of an open window to toggle between maximum full screen and minimum window display.
• Remove the toolbar buttons to maximize the screen further. In a window, select the Window > Toolbar menu commands and click on Toolbar to remove the check. Several bugs in Clintrial at the time of this writing affects some of the toolbar buttons, so it is recommended to use the menu commands or to right-click the mouse for selections.

Installing and Deinstalling Oracle and Clintrial Client Software

Installing the Oracle Client Software:
1. Insert the Oracle CD into the workstation CD-Rom.
2. Once the Oracle installer main menu appears, click on “Begin Installation”. If the Oracle installer main menu does not appear, you can open the Windows Explorer and access the root directory of the Oracle CD-ROM. From the root directory, double-click on SETUP.EXE.
3. You are then asked to confirm the installation default settings, then click OK.
4. You will then be asked to choose the type of installation, click on “Oracle 8 Client” then click on OK.
5. You will then be asked the type of user you are installing for, choose “Application User” and click OK.
6. You will then be asked where the Oracle Documentation should be put, choose “CD-Rom” and click on OK.
7. You will then be asked if you would like to view the Oracle documentation from within your browser, answer No. The Client installation is complete and the Oracle installer will be exited.
8. In order to be able to use Clintrial you must now install the Oracle “Required Support Files 7.3.4.1.1” to do this repeat steps 1 through 3 above.
9. You will then be asked to choose the type of installation, click on “Custom Installation” then click on OK.
10. The Software Asset Manager will appear. Double-click on the All Products entry on the left hand side of the Software Asset Manager window. A scrollable list will be presented; choose “Required Support Files 7.3.4.1.1” by clicking on the entry, then click on Install. This will install the Required Support Files.
11. Upon completion of the installation the Oracle Installer will notify you, at this point you must click on OK, you will be returned to the Software Assets Manager, click on Exit then Yes, to confirm that you would like to exit the Oracle Installer.
12. Reboot your computer after exit from the Oracle Installer with the resultant changes to your AUTOEXEC.BAT (or, you can wait until after Clintrial installation and network connection).
13. You are now ready to install the Clintrial client software on the workstation.

Installing the Clintrial Client Software:

1. Insert the Clintrial CD into the workstation CD-Rom.
2. Open the Windows Explorer and access the root directory of the Clintrial CD-Rom. From the root directory double-click on Setup.exe.
3. The Clintrial Welcome screen will appear, click Next.
4. You will be asked for name and company, enter these and click Next.
5. Clintrial will then ask you to confirm that the client software is to be installed in C:\CT42, click Next.
6. Choose Typical as the setup type and click Next.
7. Select Clintrial 4.2 as the Program Folder and click Next.
8. The installation will then take place, at the end of which you will be asked if you would like to view the ReadMe file. Click on Finish.
9. You are now ready to establish your network connection to the computer where the Clintrial database is located.

Establishing Network Connection:

1. Start the Oracle Net8 Easy Config module by selecting the following: Start > Programs > Oracle for windows 95 > Oracle Net8 Easy Config.
2. Click Yes to continue on past the first dialog box with a warning that comment information in the Network Configuration files may be lost or repositioned when saving your Network configuration.
3. Choose action Add New Service (database alias) and enter a name as the New Service Name. Enter ORC0 as the service name (or the current database alias at your site). Note that .WORLD is automatically appended to ORC0 in the display of available Service Names. Click Next to continue.
4. Choose TCP/IP (Internet Protocol) to connect to and communicate with the Clintrial database you want to use. Click Next to continue.
5. Enter the IP address as Host Name of the computer where the Clintrial database is located. Leave 1521 as the default Port Number. Click Next to continue.
6. Enter ORC0 (or the same name as the current database alias) for the Database SID. Click Next to continue.
7. Click Test Service to test the connection. In the database connection dialog box, enter a valid Oracle database username (for example, SYSTEM) and its password and click Test. After the test is completed, click Done to continue. If the connection test was successful, click Next from the Test Service dialog box to continue; if not successful, click Back to review and correct previous entries.
8. Click Finish to save your service name changes.
9. You are now ready to create new Clintrial user accounts.
Setting Up Client User Accounts:

1. Start the Clintrial Admin module by selecting the following: 
   **Start > Programs > Clintrial 4.2 > Clintrial Admin**
2. In the database connection dialog box, enter the User Name (for example, CTSYS) and Password that was set up with system privileges on installation of Clintrial on the server. For Database, enter your service name added in Oracle Net8 Easy Config preceded by @ (for example, @ORC0).
3. From the Security menu, select Users to get the User Maintenance window.
4. From the Edit menu, select Add.
5. Enter a name (user account) for the new User Name. A valid user name can be up to 20 characters long, alphanumeric, not beginning with a number, and without spaces or other symbols. User name is not case sensitive.
6. Enter a Password. When you save the window, you will be prompted to re-enter the password for verification. The password must conform to the parameters as set up by the system administrator (currently length set at 6). A password must consist of alpha and/or numeric characters (other symbols and spaces not allowed) and cannot begin with a number. A password is not case sensitive.
7. Accept the defaults, or change the values for:
   - Default Tablespace: CT_USER
   - Temporary Tablespace: TEMPORARY
   - Profile: DEFAULT
8. From the File menu, select Save to save the window.
10. From the Parameters menu, select System to define any special characteristics of the work environment for the user. Close the System Parameters window.
11. Close the Clintrial Admin module after the new user accounts have been created with appropriate access rights and system parameter definitions.
12. Optionally you can place a Clintrial 4.2 icon on the Desktop (for Switchboard with access to all Clintrial modules or just for Enter to perform data entry) by doing as follows. Open My Computer or Windows Explorer and select Clintrial 4.2. From the File menu, select Create Shortcut. Select the Clintrial 4.2 shortcut and drag the shortcut onto the Desktop by holding down the left button of the mouse.

Deinstalling Oracle and Clintrial Client Software:

To delete Oracle and/or Clintrial client software from a computer, say, to restart installation after an unsuccessful attempt, use the following deinstallation instructions.

To deinstall Clintrial Client Software, do the following.
1. Double-click on the icon for My Computer.
2. Double-click Control Panel.
3. Double-click Add/Remove Programs.
4. Select Clintrial 4.2 and click Add/Remove.
5. The directory C:\CT42 can be deleted from Windows Explorer or by the RD DOS command at an MS-DOS command prompt.

To deinstall Oracle Client Software, do the following.
1. Start the Oracle Installer module as follows: **Start > Programs > Oracle for Windows 95 > Oracle Installer**.
2. Select all Oracle modules (shift-down arrow) in the rightmost column labeled “Products Installed at C:\ORAWIN95” and click Remove. The Oracle Installer remains installed and does not need to be deleted if Oracle will be reinstalled.
5.2 System Parameters

Clintrial system parameters define the characteristics of the work environment for all users of an Oracle database to which the users connect through Clintrial. These system parameters are set in the Clintrial Admin module from a user account that has the Admin System access right. In Admin and in the following table, system parameters are grouped by the module to which they pertain.

Parameters of type ‘System’ cannot be overridden. Those of type ‘Protocol’ can be overridden by modifying protocol parameters within the Design module. Those of type ‘User’ can be overridden by user preferences for each module (or Group). For JHS, the ‘System’ parameters are set for the study and do not override the values within protocol or user.

The table below lists the parameter value to be used in JHS and a description of what the value means. If the description is blank, no value has yet been determined.

<table>
<thead>
<tr>
<th>Group</th>
<th>Type</th>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin</td>
<td>System</td>
<td>PASSWORD_ENCRYPTION</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>SAVE_STATS</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>ACTIV_LOG_END</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>ACTIV_LOG_START</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>PASSWORD_EXPIRE_DAYS</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>PASSWORD_MINIMUM</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>USR_DB_PROFILE</td>
<td>DEFAULT</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>USR_DFT_TSP</td>
<td>CT_USERS</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>USR_TMP_TSP</td>
<td>TEMPORARY</td>
<td></td>
</tr>
</tbody>
</table>

| Manage | System| ALLOW_MERGE_TO_VALID              | Yes     |                                    |
|        | System| AUDIT_REASON_REQD                 | Yes     |                                    |
|        | System| AUTOCODE_FULL_CNT                | No      |                                    |
|        | Protocol| AUTOCODE_RECODE_ALL            | No      |                                    |
|        | System| AUTOCODE_SET_FAIL                | Yes     |                                    |
|        | Protocol| ENCODE_CLEAR_ITEMS              | Yes     |                                    |
| User   |             | SELECT_BY_PAGE                    | Yes     |                                    |
| User   |             | AUDIT_ITEM_LIST                   |         |                                    |
| User   |             | ERRLOG_DISPLAY_ITEM               |         |                                    |

<p>| Entry  | User  | DD_BLANKS_IN_PATIENT             | No      | Blank spaces not allowed in subject item. |
|        | User  | ENT_AUTOSKIP_DFLT                | No      |                                             |
|        | User  | ENT_ENTER_AS_TAB                 | Yes     | Enter key acts as Tab key.                 |
|        | User  | ENT_FORM_INSERT                  | Yes     | Data is saved automatically when a page is closed. |
|        | User  | ENT_OPEN_NAVIGATOR               | Yes     |                                             |
|        | User  | ENT_TAB_PAGE_FORWARD             | No      | In last field on page, Tab key moves to first item on current page. |
| Protocol|       | VERIFY_BLIND                     | Yes     |                                             |
| System |       | VERIFY_SHOW_TAGS                 | Yes     |                                             |
| User   |       | ENT_ENR_STUDYBOOK                |         |                                             |
| User   |       | ENT_OPEN_PAGES                   | 1       | Number of study pages that can be opened concurrently. Increase to 10 temporarily to print study book or do QBF. |</p>
<table>
<thead>
<tr>
<th>Design</th>
<th>System</th>
<th>AUDIT_INVNOTES</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Protocol</td>
<td>AUDIT_METADATA</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>AUDIT_PROTOCOL_MOD</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>AUDIT_SponsorNotes</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CONNECT_REQD_DD</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CONNECT_REQD_FRM</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CONNECT_REQD_VLD</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CREATE_OBJ_DD</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CREATE_OBJ_FRM</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>DD_AUTOVALIDATE</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>DD_NAME_UPDATE</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>DD_STRICT_CODE</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>DD_STRICT_SEARCH</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>FRM_CODEENTRY</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>FRM_OVERRIDE</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>FRM_USE_DESCRIP</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>AUDIT_START_DEFAULT</td>
<td>MERGE</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>DD_DBMT_FIXED</td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>DD_DBMT_FLOAT</td>
<td>NUMBER(6,2)</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>DD_DBMT_TEXT</td>
<td>VARCHAR2(20)</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>PROC_ACCOUNT</td>
<td></td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>PROC_SITE_ACCOUNT</td>
<td>CTSITEPROC</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>PROT_TMP_TSP</td>
<td>TEMPORARY</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>XFER_TABLESPACE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Retrieve</th>
<th>User</th>
<th>RTV_INCL_SYS</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>RTV_DEF_DECODE</td>
<td>0</td>
<td>Codelist column used for decoding: 0=code, 1=value.</td>
</tr>
<tr>
<td>User</td>
<td>RTV_SAS_RECLEN</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>RTV_DEF_SOURCE</td>
<td>DATA</td>
<td>From data tables only. ALL includes both update and data tables.</td>
</tr>
<tr>
<td>User</td>
<td>SAS_LIBNAME</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resolve</th>
<th>System</th>
<th>CTV_USE_ERRORLOG</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>CTV_APPL_RES_CODE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>CTV_AUTOCLOSED_RES</td>
<td></td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>CTV_OBSOLETE_RES</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>CTV_FIRST_HEADER</td>
<td>Company Name</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_FIRST_HEADER_PR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>CTV_REQUESTER</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_REQUESTER_PR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>CTV_SECOND_HEADER</td>
<td>Discrepancy Form</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_SECOND_HEADER_PR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_SELECT_INVESTIGATION</td>
<td>See 1 below</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_SELECT_SUBJECTS</td>
<td>See 2 below</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_SELECT_VISITS</td>
<td>See 3 below</td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_SELECT_VISITS_1S</td>
<td>See 4 below</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>CTV_STARTUP_VIEW_ALL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protocol</td>
<td>CTV_STARTUP_VIEW_PR</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
1) SELECT UNIQUE CT_RESOLVE_USER.INV_ID('<SUBJECTITEM>', '<PROTOCOL>') FROM<PROTOCOL>.SUBSTITUTE*PANEL_SUBSTITUTE*DBTABLE

2) SELECT UNIQUE <SUBJECT_ITEM> FROM <PROTOCOL>.SUBSTITUTE*PANEL SUBSTITUTE*DBTABLE
WHERE CT_RESOLVE_USER.INV_ID('<SUBJECT_ITEM>', '<PROTOCOL>') = 'SUBSTITUTE*INVESTIGATOR'

3) SELECT UNIQUE <BLOCK_ITEM> FROM<PROTOCOL>.SUBSTITUTE*PANEL SUBSTITUTE*DBTABLE

4) SELECT UNIQUE <BLOCK_ITEM> FROM<PROTOCOL>.SUBSTITUTE*PANEL SUBSTITUTE*DBTABLE
WHERE <SUBJECT_ITEM> = 'SUBSTITUTE*SUBJECT'

<table>
<thead>
<tr>
<th>Lab Loader</th>
<th>User</th>
<th>CTL_TEST_MODE</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>CTL_DUPFLAG_LOC</td>
<td>DATA</td>
<td></td>
</tr>
<tr>
<td>Classify</td>
<td>System</td>
<td>CTG.Allow_CHANGEWEB</td>
<td>Yes</td>
</tr>
<tr>
<td>System</td>
<td>CTG.AUTOACCEPT</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>CTG.EDIT_SYNTAX</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>
5.3 Adding New User and Usergroup Accounts and Assigning Access Rights

Adding a New User Account

Each Clintrial user must have a user account consisting of an ID and password to work with Clintrial modules. Multiple users with similar access needs (for example, data entry personnel) can be assigned to a usergroup, which allows you to assign and modify their access rights as a single set.

To add a new user, do as follows:

1. Login to the Clintrial Admin module.
2. From the Clintrial Admin window, select Security > Users. The User Maintenance window opens.
3. In the User Maintenance window, select Edit > Add. The cursor is placed in the User Name field. Do as follows:
   a. Enter a name for the new user for User Name.
   b. Enter a password for Password. When you tab from the field or save the window, you will be prompted to re-enter the password for verification. Follow the password requirements at the beginning of this manual. You may choose to assign a generic temporary password to new users, which they can later change themselves.
   c. Accept the defaults for the remaining fields.
   d. Close the window from File > Close or from the window’s X button to return to the Admin window.

To modify a user password, do as follows:

1. Follow steps 1 and 2 for a new user to login to Clintrial Admin and to open the User Maintenance window.
2. In the User Maintenance window, do as follows:
   a. Select a user in the Select User list.
   b. Enter a new password. When you tab from the field or save the window, you will be prompted to re-enter the password for verification.
   c. Close the window from File > Close or from the window’s X button to return to the Admin window.

To delete a user, do as follows:

1. Follow steps 1 and 2 for a new user to login to Clintrial Admin and to open the User Maintenance window.
2. In the User Maintenance window, do as follows:
   a. Select a user in the Select User list.
   b. Select Edit > Delete.
   c. Close the window from File > Close or from the window’s X button to return to the Admin window.

Note that upon deletion, the user will automatically be removed from any associated usergroups.

Creating a Usergroup Account

Usergroups are sets of individual user accounts. Grouping of user accounts provides an easy way to manage access rights for multiple accounts with identical access requirements. Once a group is created and its rights defined, its members automatically receive those rights and any subsequent modifications.

Clintrial Help provides the following information about usergroups:

• Belonging to a group does not prevent a user from having individual access rights beyond those of the group.
• Users can be associated with one or more usergroups.
• In the case of a user whose individual access differs from that of the usergroup, or in the case of a user belonging to multiple usergroups with contrasting access rights, the highest access level always takes precedence.
• Deleting a usergroup does not delete its members’ individual user accounts.
• When planning a usergroup, consider the following: What Clintrial activities will this group perform? What study data or metadata does this group need access to? For the specified data, what tasks does this group need to perform, for example, read and write tasks?
• Clintrial supplies three predefined usergroups. These groups can be used as is, modified as necessary, or deleted altogether. The groups and their default access rights are as follows:

<table>
<thead>
<tr>
<th>Group</th>
<th>Module</th>
<th>Type</th>
<th>Access right</th>
<th>Access levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMIN</td>
<td>Admin</td>
<td>Non-protocol</td>
<td>DBA</td>
<td>Full</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>System</td>
<td>Full</td>
</tr>
<tr>
<td></td>
<td>Design</td>
<td>Non-protocol</td>
<td>Global</td>
<td>Full</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>System</td>
<td>Full</td>
</tr>
<tr>
<td></td>
<td>Tools</td>
<td>Non-protocol</td>
<td>SQL</td>
<td>Full</td>
</tr>
<tr>
<td>ANALYSIS</td>
<td>Retrieve Protocol</td>
<td>Merged</td>
<td>Read</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Library</td>
<td>Write</td>
<td></td>
</tr>
<tr>
<td>ENTRY</td>
<td>Enter</td>
<td>Protocol</td>
<td>Unmerged</td>
<td>Full</td>
</tr>
</tbody>
</table>

To create a usergroup, do as follows:

1. Login to the Clintrial Admin module.
2. From the Clintrial Admin window, select Security > Usergroups. The Usergroup Maintenance window opens.
3. In the Usergroup Maintenance window, do as follows:
   a. Select Edit > Add. An Add Usergroup dialog box opens. Enter a name for the new usergroup for Usergroup Name and click OK. A usergroup name can be up to 20 characters long, must be alphanumeric, and cannot begin with a number. A usergroup name is not case sensitive.
   b. To add or remove group members, see below.
   c. Close the window from File > Close or from the window's X button to return to the Admin window.

To delete a usergroup, do as follows:

1. Follow steps 1 and 2 to create a usergroup to login to Clintrial Admin and to open the Usergroup Maintenance window.
2. In the Usergroup Maintenance window, do as follows:
   a. Select the group you want to delete from the Usergroups list.
   b. Select Edit > Delete.
   c. Close the window from File > Close or from the window's X button to return to the Admin window.

To add or remove group members, do as follows:

1. Follow steps 1 and 2 to create a usergroup to login to Clintrial Admin and to open the Usergroup Maintenance window.
2. In the Usergroup Maintenance window, do as follows:
   a. Select a group from the Usergroups list.
   b. To add users, select from the Non-members list and click <<.
   c. To remove users, select from the Members list and click >>.
   d. Close the window from File > Close or from the window's X button to return to the Admin window.

Assigning Access Rights
Clintrial Help provides the following information on access rights:

Once a user account or usergroup has been created, the Clintrial administrator must assign access rights for the new account. Access rights determine a user or usergroup’s ability to access data and perform tasks in Clintrial.

An access right is composed of the following two parts:

- The **access right**, which specifies the data type or action in question (for example, merged data).
- The **access level**, which specifies what can be done with that right (for example, read or write).

There are the following three categories of access rights:

- **Protocol** access rights control access to data and actions related to a specific protocol.
- **Non-protocol** access rights control access to data and actions independent of specific protocols. For example, the ability to use SQL.
- **Protected Panel** access rights control access to protocol panels that have been designated as "protected" in Design. To work with a panel of this type, the user must have access to both the protocol and the panel itself.

Within each of these three categories, access rights are further grouped by the Clintrial module.

The simplest and most effective way to assign access rights is through usergroups. Once a group is created and its rights defined, its members automatically receive those rights. Rights for a particular user are typically only defined when additional access beyond that of the group is required by a user.

In the case of a user whose individual access differs from that of the usergroup, or in the case of a user belonging to multiple groups with contrasting access rights, the highest access level always takes precedence. For example, if user X has write access to Admin, but X's usergroup access is read-only, the higher (write) access takes precedence.

By default, newly defined users and usergroups have no access rights. Exceptions are Clintrial's predefined user account (CTSYS) and usergroups (Admin, Analysis, Entry).

To assign access rights, do as follows:

1. Login to the Clintrial Admin module.
3. In an access rights window, select a row to which you are assigning access. For each Clintrial module, select the appropriate access level from the drop-down list. The list displays automatically when you click in a field. The dash (-) signifies No Access. If a user belongs to any usergroups, the usergroups are listed as unavailable rows under the user's name.
4. Close the window from **File > Close** or from the window's X button to return to the Admin window.

To copy settings from one row to another in an access rights window, do as follows:

1. Click a field in the row you want to copy from.
2. Select **Edit > Copy Row**.
3. Click a field in the row you want to copy to, and select **Edit > Paste Row**.
5.4 Administering Clintrial and the Oracle Database

This appendix may later include information on topics such as daily monitoring of data table space, installing Oracle and Clintrial service releases, and updating the DMS.

Typical users and of the Clintrial modules

Clintrial consists of five integrated core modules (listed below) and a Clintrial Switchboard that provides a single point of access to the Clintrial modules. Supplemental modules that extend the basic Clintrial functionality are also available.

<table>
<thead>
<tr>
<th>Module</th>
<th>Use to</th>
<th>Typical user</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin</td>
<td>Create user and usergroup accounts. Set up and manage access rights for users, usergroups, and protocols for all Clintrial modules. Set system parameters. Monitor database space. Produce reports about system activities.</td>
<td>Clintrial Administrator or Database Administrator</td>
</tr>
<tr>
<td>Design</td>
<td>Design the study database to model your study protocol. Define data structures for storing study data. Create study books that are online representations of a set of data collection forms for data entry.</td>
<td>Designer or Programmer</td>
</tr>
<tr>
<td>Enter</td>
<td>Add (enroll) subjects to a study. Enter study data interactively. Verify (re-enter) study data. Edit study data. Add flags and notes to study data. Produce reports about study data.</td>
<td>Data-Entry Operator</td>
</tr>
<tr>
<td>Manage</td>
<td>Batch load study data. Code study data using a coding thesaurus. Validate data (run derivations and rules). Globally change or delete records. Edit records based on an Error Log report. Review an audit report of changes to study data.</td>
<td>Data Manager</td>
</tr>
<tr>
<td>Retrieve</td>
<td>Extract study data from the Oracle database using SAS. Create simple or complex queries using SQL from Clintrial.</td>
<td>Data Manager or Medical Reviewer</td>
</tr>
</tbody>
</table>

Monitoring data table space

At installation, Clintrial sets default storage parameters for its Oracle tablespaces. Using the Admin module, the Clintrial Administrator can view and modify these storage parameters and can regularly monitor the growth of the database (e.g., run Reports > Space Utilization for tables and indexes).

Frequent monitoring of the tablespaces by the Database Administrator is recommended. Clintrial does not recognize when tablespace limits are approached, and a protocol could be damaged if space allocations are exceeded.

Manuals on Oracle DBA administration are available from the Oracle Corporation. Another source for information is from books by users such as Oracle Performance Tuning by Mark Gurry & Peter Corrigan from O'Reilly & Associates, Inc.
5.5 Blind Verification Procedure

Introduction

Verification or double data entry is the process of re-entering study data to compare the old and new values, checking for data entry errors or value conflicts.

Clintrial supports two types of verification: interactive verification and blind verification.

For the JHS, selected study data are re-entered using blind verification. The forms that are verified are those forms completed on paper (enumeration, home induction interview, Approach to Life A-C, and Hassles and Moods A-D forms).

Blind verification is performed in the Enter module, and reports on verification errors are generated in the Enter module on ‘unmerged’ data in the update tables.

JHS DMS Form Design and Its Significance in Verification Error Checking

A single form or study page is usually made up of multiple records (panels or page sections), each containing a unique subset of items (fields) for the form.

Knowing that a form requires verification, the designer sets the Verify attribute for usually all the panels for that form from the Panel Browser in the Design module.

Following blind verification, not all the records (or panels) for a single form may have the same record status. For example, the ELGA Eligibility form is composed of seven records. If only an item contained in the first panel of this form has a value conflict from blind verification, then only the first record for the form containing this item receives a record status of Verify Error; the other records for the same form receive a record status of Verified.

What is Blind Verification?

In blind verification, Clintrial compares old and new values when you save a study page re-entered in the Verify edit mode. During blind verification, the new values do not overwrite the old ones, nor can you choose which value to retain.

If there is a value conflict, a record status is changed from Unverified to Verify Error, otherwise a record status is changed to Verified. Clintrial also attaches a VERIFICATION/AUTOFLAG flag to an item with a value conflict. The VERIFICATION/AUTOFLAG flag comment contains the original and re-entered values and the user accounts of the data-entry operator(s) who entered the values.

Reviewing Blind Verification Results

Three Clintrial reports accessed from the Reports menu in the Enter module can provide results on the blind verification. These reports are the Verification Report, Subject Report, and Flag Report. Only subjects in the update tables are included in these reports. Once created, these reports can be viewed online, printed, or saved to a file.

The Verification Report (record level) contains a list of records with a status of Verify Error.

A Detailed Subject Report (record level) can contain a list of all records for a form(s) and their record status.
A Detailed Flag Report (item level) can include items with a VERIFICATION/AUTOFLAG flag, along with the comments containing the original and re-entered values and the user accounts of the data-entry operator(s) who entered the values.

The Flag and Subject reports are available in two basic formats: detailed and summary. The detailed format provides in-depth information on the attributes of each record that it retrieves. The summary format gives a count and categorical breakdown of the records it finds. You can tailor each report by entering criteria prior to generating it using the Report Wizard.

The Clintrial Help menu provides in-depth information on these three reports. Select Help > Help Topics in the Enter module. You can find information under the Contents tab in Enter Reports, and you can find information under the Index tab for ‘reports’.

Special note on reviewing verification results: A form with any of its records and items marked with verification errors should not be changed and set to Verified until all verification results are reviewed for that form. When you open a form in the Navigator after blind verification and set it to Verified on closing, you will lose information on all value conflicts for that form. That is, all VERIFICATION/AUTOFLAG flags on items for the form will be removed and every Verify Error record status for the form will be changed to Verified.

Special note on Clintrial reports: The Verification Report and Subject Report may not accurately show a record status of Verify Error when an item in that record has a VERIFICATION/AUTOFLAG flag. The Flag Report appears to be the most accurate listing on blind verification errors. It is advisable to review the Verification Report, Subject Report, and Flag Report together for a comprehensive review of all records entered (Subject Report) and those with verification errors (all three reports but most accurately the Flag Report).

Performing Blind Verification

In preparation for blind verification, the Enter module VERIFY_BLIND protocol parameter must be set to Yes in the Admin module by your Clintrial administrator. You can only open a form for blind verification if its panels were set with the Verify attribute in the Design module by the designer. You can only verify forms in the Enter module that are in update tables and that have a panel status of Unverified.

The steps to verify forms using blind verification are as follows:

1. From the File > Edit Mode menu, set the edit mode to Verify.
2. In the Navigator, select the form (study page) that you want to verify.
3. Enter data in all fields.
4. Save the changes when you are done. Once saved, the record(s) for the form have their status changed from Unverified to Verified or Verify Error, and the form cannot be verified again.

Flags and notes themselves do not need to be verified. However, you can attach, modify, or delete flags and notes during verification if the system parameter VERIFY_SHOW_TAGS is set to Yes (all flags and notes are available) in the Admin module by your Clintrial administrator.

During blind verification, Clintrial automatically attaches a VERIFICATION/AUTOFLAG flag to a field if you re-enter a value that is different than the original value or if you leave blank a field that originally had a value. A VERIFICATION/AUTOFLAG flag comment contains the original and re-entered values for the field and the user accounts of the data entry operator(s) who entered the values.

Modifying Data after Blind Verification and after Verification Results Review

To change a record status from Verify Error to Verified, open the form after blind verification in Edit Update Table mode that is set from the File > Edit Mode menu in the Enter module. You can add to or change the original values of any fields or retain the original values. When you save the form and set the
form to Verified, then all records for the form receive a status of Verified and all
VERIFICATION/AUTOFLAG flags are removed from fields in the form.

When you modify or delete data in the update tables, you may be required to provide a Reason for
Change. A Reason for Change is an explanation appended to an individual record explaining why the
record was modified. The Reason for Change dialog box opens automatically when you edit a record.
Enter an explanation directly into the Reason for Change Text box. To apply the Reason for Change to
the current record only, click OK. To apply the Reason for Change to all modified records for a form, click
Apply To All Changes.